Hardware Problem#2

Hi Guys,

I’m new to Cubase Pro 8 and this is my second post. So far, I’ve seen a number of Steinberg videos on YouTube, and I fairly know how to use Cubase (just plug and play), but my only problems seems to be hardware (connecting and getting sound). Cubase Pro 8 isn’t that difficult, honestly.

#1) I replied to a nice person from my first post, but I’ll include it in here to get some other opinions. Since my digital piano has no MIDI OUT/IN, it has a USB instead but it still functions as a MIDI keyboard according to the manual (Williams Legato 88-key). I connect it, the PC picks it, so does Cubase. I know how to link the digital piano to the tracks on Cubase, simple as sin. But no sound comes out. For example, let’s say that I select “instrument track” and I set up a VST/MIDI grand piano from Helion. When I go to play my digital piano, Cubase doesn’t pick up my piano, but instead I can still play my piano as if it wasn’t connected to the PC and the sounds still comes from its speakers, so no sound from it is transmitting to Cubase at all!

2#) When I plug in the UR22 while using Cubase, I obviously plug in my headphones as well using a 1/4 inch connector with the headphones. However, I noticed that when I was playing around Groove Agent, I heard the sound coming from my pc and not from my headphones. Yet when I hear music from YouTube or from any other player, I can hear it from my headphones and not from the computer speakers. I am just really confused. I really need help connecting the audio in place.

If you can please be specific and point me in the right direction, I’ll be so happy. I just want to start recording my songs already!

Hi,

I don’t think it’s necessary to start a 2nd topic since they’re related, but it’s ok, let’s continue here.
I’m going to start with #2 because it’s part of the problem in #1. If you are hearing your Cubase audio coming from speakers that are not connected to the UR22, then you have the wrong audio driver selected in Cubase. Go to:
Devices --> Device Setup --> VST audio system
In this menu, click the ASIO driver dropdown and select the Steinberg ASIO driver. Cubase is now able to access the audio in and outputs of the UR22.
Click OK to get rid of the device setup window. To be sure, press F4 to open the VST connections window. You should see UR22 in and outputs mapped to in and output busses here. I don’t know the default behaviour for assigning input busses, but I’m guessing Cubase made mono input busses for you. Because you’re going to record a stereo signal from your piano, delete the mono input busses and create a new stereo input bus. Assign the 2 UR22 jack inputs to this bus. You can give the bus a name (like ‘Piano input’) which makes it a bit easier to find later on. The output busses are probably assigned right by default, so you can take a look but I don’t think you’ll need to touch them, unless you’re still not hearing Cubase output in your headphones.

Back to #1: A couple of things going on here. You don’t mention if Cubase is receiving midi from your piano or not. If not than that needs to be fixed first, you’re not going to get audio from your instrument track if it’s not receiving midi.
Secondly, you need to press the monitor button on your instrument track (the little speaker icon, it has to be orange) for it to respond to your piano as you play.
Thirdly, the correct ASIO driver should be selected, but I covered that above.
Finally, you’re still hearing your piano. That makes perfect sense because your piano doesn’t know it’s being used to trigger another instrument instead. You’ll have to tell it that explicitly. Look in the manual of your piano for the Local ON/OFF function. If you set it to off, the keys of the piano will be disconnected from the sound generator, but they will still send midi data so you can play your instrument track. Additionally (although this is not relevant to what you’re doing now), with Local OFF, the sound generator of the piano will still respond to incoming MIDI. If you use Cubase to route the incoming midi from the piano keys back to the piano, you can still play your piano even though Local is set to OFF. This can be very convenient because pressing monitor on a track is usually easier than switching between Local ON and OFF on your piano all the time, in case you’re working on a project that uses both instrument tracks and your piano sound.

Anyway, post is long enough for now. Let us know how you get along. If everything works, be happy and make some music :wink:. Try recording some of your piano playing in midi as well as in audio, so you get the hang of both.
Best of luck!

Strophoid,

I got some great news! Everything works. I did everything you instructed, but I didn’t have to change anything, because it was already done by Cubase. I have no clue what happened last night, but it works now, strangely. I think I know the secret: connect everything before opening Cubase. If I have more issues, I’ll send you a private message. Thank you!

Glad to hear :slight_smile:
Have fun!

Hi Strophoid,

Hopefully this will be my last question (I REALLY DO HOPE!!). How can I remove the latency? I know that you have to adjust it from the Device Setup menu, which is simple, but remember that my piano isn’t connected to the interface, unlike my guitar and bass, so I can’t really select Direct Monitoring to ease the issue. When I record piano, the latency is so bad! What other methods is there to reduce it besides from the device setup? Any tips will be much appreciated!

Where exactly are you experiencing latency? When playing an instrument track from your piano?
The only thing you can do to reduce the latency, is decreasing the buffer size in your ASIO driver.
Go to Device Setup --> VST Audio system. There should be a button here that says something like ‘control panel’. This should open the Steinberg/Yamaha ASIO driver control panel, where you can change the buffer size. Put it at the lowest possible setting and see if that solves the latency. You may experience audio dropouts at this setting (pops and clicks in your audio, or interuptions while recording). If that is the case, increase the buffer size step by step untill they disappear. What setting that is depends entirely on your computer system and how much stuff is going on in your projects. Generally speaking, a buffer size of 128 or lower shouldn’t have any noticable delay at all. If you need to go higher, judge for yourself what you can or can’t live with.
If this doesn’t solve your latency problem, something is going on with your midi timing. It’s been ages since I looked at that so I can’t really help you there off the top of my head. Something to do with DirectMusic and something else I believe…

I would be surprised if this is your last question, there’s so much more to learn :wink: