Harp pedal conundrum

If I want to show the second pedal setting in the image as a diagram as well, how would that be done? The Appearance: Diagram property override has no effect, hence the noob question…

(pay no attention to the mess, that’ll be fixed later)

There’s an Engraving Option for whether partial pedallings should be shown as diagrams or note names. By default it’s set to 3, meaning that where three or fewer pedals change, note names are always shown. I would imagine that if you set it to 0 you’ll always get a diagram.

1 Like

It looks like a partial pedaling. I don’t think you can show those with the diagram. No option for this, I am afraid.

I know about the global setting but that then applies to the entire >250-page score, and elsewhere I do want to show partial changes. That’s why the local override would be useful—if it actually worked as expected. Entering it as a complete diagram doesn’t work, either. I know this is difficult to phrase without sounding indignant, but why does the “Appearance” override not do what I want it to?

Oh and ticking/unticking the “Partial pedaling” checkbox also does nothing, as far as I’m aware. If I don’t regain some kind of control over the appearances in the way the Properties make me think I have, I might just completely revert to the dedicated fonts we used as a workaround before v3.

You can do what you want with the functionality as it currently exists, but you’d need to turn off the global option for partial pedallings, then select all Harp Pedal Changes and set them locally to show as partial pedallings. It’ll be a faff to go through the part and work out which ones should show as diagrams and which ones shouldn’t, I realise.

I must be missing something fundamental here, in which case, apologies for being stupid. If I switch off the Engraving Option to Show partial changes up to x pedals, now everything is a diagram and nothing I do in the Properties locally changes them back into note names, partial or not.

Having played with it a little more, I think you’re right. Sorry. The properties don’t seem to have the usual ability to override the global settings.

AHA, got it. When I switch “Set local properties” to Locally, things work as expected again. Why this has to be the case however seems a mystery to me.

1 Like

Ah. Bingo. Good call.

In case you need it, though, there’s a possible cheat, which is to fool Dorico into changing more than three pedals. You can do this by adding then hiding another pedal change, like so: