Have I fried my UR28M?

Hi - Until yesterday I was running great with Cubase Pro 11 on a Windows Surface Pro 6 and a UR28M in a hub (the Surface Pro has only one USB port), all in W10.

I inadvertently disconnected the USB while running Cubase and have not been able to run Cubase with the UR28M since.

I can run Cubase with the generic ASIO driver, but as soon as I change over to the UR28M, Cubase dialog reports that it has removed the audio device. When I check in Device Manager and the Yamaha Steinberg USB Driver Control Panel, the device (which was there just before) is now indeed missing.

Would anyone have any suggestions please?

Things I have tried (with multiple shut down/restarts of the computer in between), that did not seem to work:

  1. Add/Remove Basic FX, UR28M Applications, and the Yamaha Steinberg USB Driver, re-downloaded the “Tools for UR28M”, then reinstalled all those three again
  2. Removed the actual UR28M via Device Manager and reinstalled
  3. Tried to update UR28M firmware (it says it has the most recent update)
  4. Used factory Cubase Preferences
  5. After one of the Tools for UR28M uninstall, I reinstalled an older version of the software, noticing that a newer version had been uploaded just a few days ago, thinking maybe the newer version of the Tools was somehow incompatible with my computer or maybe hardware.
  6. Run the USB e-Licenser Control Center Maintenance many times
  7. Other things (sorry, my brain is fried, can’t recall at the moment).

Basically, every time I ask Cubase to switch from the Generic ASIO driver to the Yamaha driver, it says it has removed my hardware (UR28M) from the computer, and indeed it has.

Thanks for any help!

PS: Because I couldn’t think of anything else to try for now, I tried to use the UR28M while running Cubase Pro 9 instead of CP 11. Same outcome - Cubase “removed” the UR28M, making the interface unavailable for use.

Have you also disconnected your computer from the 230V mains for at least a minute?

Hi @P.A.T !

Thanks for the suggestion, haven’t tried that one (I’ve had the ur28 unplugged for an extended period of time, both power and USB), will do that with the computer as well today.

I guess I should contact Steinberg hardware support if that doesn’t work. :frowning:

Is it reasonably possible that I might have permanently ruined my UR28M by inadvertently pulling its USB cable out while using Cubase 11 Pro?

I noticed that before UR28M failure there is sometimes an error message along the lines of, "Cubase Artist 11 (please note, I’m using Cubase Pro 11) has caused the following error:

Connection to protection device is lost".

I got that message even after deleting and redownloading/reinstalling e-Licenser Control Center.

I wonder if I should re-download Cubase Pro 11 itself? (I wouldn’t think so, since even now Cubase 11 Pro works just fine if I choose the generic low latency ASIO driver).

Thanks again! :blush:

Thanks, @P.A.T -

I did try that (disconnected my Surface Pro 6 from the mains overnight), deleted/re-loaded all the specific Tools for UR (I reloaded the last version I had, pre-update, known to work well), and it didn’t work. Thank you for trying to help me out!

In the hope that someone may recognize what has gone wrong on my system, I’m adding another few observations here:

  1. When I execute the Tools for UR28M setup.exe file I downloaded, I notice that:
    a) all three components did execute (driver, applications, Basic FX), but in the dialog before that the Basic FX option, though checked, is grayed out … even if I wanted to it would not let me uncheck that option. Is that OK?

  2. Once Cubase opens, the only Audio System visible in Studio>Studio Setup is the Generic Low Latency ASIO Driver - the UR28M is not listed. However it is listed in the Device Manager as “UR28M” in the “Sound, video and game controllers” section, and I can open the Control Panel via START > Yamaha Steinberg USB Driver, and see the UR28M with latency, “Standard” mode, etc. Why isn’t it listed in Cubase, even though it is listed in my computer in both those places?

  3. When I do the step in the instructions for “Device Connection”, even though the end result seems good as above (the UR28M being listed in Device Manager>Sound, video and game controllers, and in the START > Yamaha Steinberg USB Driver control panel), Step 10 of the “Device Connection” instructions never took place - I never saw a dialog to click or unclick “Install the software automatically”. The installation seems to have occurred without any dialog at all.

Is any of this helpful for trouble shooting?

Thank you for any more suggestions! :slight_smile:

The Basic Fx Suite is completely independent of the UR hardware. They are VST plugins that emulate DSP effects that are hardwired into the UR. These VST effects can be used in the DAW even if no UR interface is connected, e.g. to exactly reproduce the sound when recording.
Why are the Basic Fx greyed out? Perhaps there is no license for this on the eLicenser?
image

For Cubase, the Yamaha Steinberg USB ASIO driver is crucial.
If it is installed correctly, the UR28M is addressed via it.
image
image

Since the UR28M is available in Windows, the following question:
Does the dspMixFx software work correctly for you?
If so, the problem seems to be related to the ASIO driver.

It works!

Thanks for your time and help, @P.A.T !

What finally happened was the UR28M wouldn’t even power up any more.

I remembered reading this thread for what to do if that happened, UR28M won’t turn on - Steinberg Hardware / UR Series - Steinberg Forums, and so that’s what I did (held power button for 60 seconds, etc.).

Lo and behold, it did power up, and more to the point, everything works again now - the UR28M, and associated Basic FX, are now playing nicely with Cubase 11.

Does any one have any ideas what happened that made Cubase not see the UR28M after the USB was disconnected with Cubase running, and why this fix worked?

Parenthetically, I was on the phone with Yamaha help - I waited only about 5 minutes or so, and got a really chill, extremely knowledgeable and helpful person. I was kind of embarassed because after telling her I’d been trying for hours and nothing worked, it all worked just fine as I was trying to reproduce the problem step by step with her on the phone (even though it hadn’t worked just a few minutes before)!

Anyway, all is good, hopefully the Steinberg/Yamaha driver gods have gotten their pound of flesh from me and I’ll be OK for a while …

:slight_smile:

2 Likes