Have never gotten repeats to work

I’ve been using Dorico 4 for several months now and have never gotten a repeat to work. Never. I’m not doing anything fancy, other than telling Dorico to repeat a contiguous range of measures n times in the lower-panel inspector box.
I even made up a little test file that consist primarily of a single repeated section. Still does not repeat. Screenshot attached.
I haven’t found anything on-point in the operations manual, but I feel like I must be missing something obvious. Is there some special way to enable repeats or play a score with repeats?

Check Library > Playback Options > Repeats > Play repeats

Thanks, Dan – that worked!
I’m not surprised that there was some setting causing my problem, but I would never have expected that such a common scoring function would be disabled by default. Or that the requirement wouldn’t be mentioned in the Operations manual in the section that describes how to create a repeat.
Anyway, thank you again for the quick response. The people on this forum are the best!

That option isn’t disabled by default, but it will be disabled automatically by Dorico when opening your project, if you have created an invalid repeat structure that will repeat infinitely.

1 Like

(And it won’t automatically turn the option back on if hours/weeks/months later you fix the repeat structure.)

1 Like

Holy cow!!
Yes, when I first installed Dorico, I was playing around with things like repeats to learn how the various palette options worked and in so doing, may have momentarily created an invalid repeat structure. That’s all it took to permanently disable all repeat functions? I need to digest that.

It’ll have disabled playback of repeats within that project.


The real problem is that once repeats work, if the project is exported to print, as a .pdf, the measure numbers don’t reflect the repeats. This makes it very difficult to match the printed score with the MIDI that is eventually imported to Cubase. That is, the score view of Cubase will not match the score view of Dorico. Did no one ever actually use this software or is this all just a big joke by Steinberg?

Darn it, you found out. All the people on this forum who supposedly use Dorico professionally? They’re all trolling.


Welcome to the forum @al.rushing – you can find information about the options available to you for how to represent repeats in bar numbers starting on this page; the instructions for how to achieve each separate thing mentioned are on following pages, which you can navigate to using the link at the bottom right/left of each page.

Welcome to the forum!

While they are working to tighten integration between the two programs, you do need to remember that they are indeed two separate programs… so it is hardly surprising that they handle midi data differently.

1 Like

Short answer: Engraving Options > Bar Numbers, the first setting.

1 Like

The following regards V3:

So, the answers are “tough luck” or settings, where there is no reference to repeats that I can find. I could restart the measures manually at each repeat perhaps, not sure if that would work, but it’s a good bit of effort.

So, how to people handle this issue? Certainly they go from Dorico to Cubase all the time. Do pros actually use this software? Hard to believe.

I am going to need to upgrade to V4. No problem but I am terrified about this new security. I cannot afford to be without my composing software in my current project. By next month I should be able to shut everything down for a few weeks while the technical problems get sorted out, if they can be. I can’t even get my Absolute 4 or Backbone to work with Dorico and all is licensed just so.

Would love to see the UML on this software. Seems like amateur hour from my perspective.

The below links sound like the options you’re looking for, and as far as I’m aware, they were available in Dorico 3. Do they produce the results you want?

Are you using Dorico Pro? You haven’t said. The other versions do not offer Engraving Options.

Well, Leo, after re-enabling repeats, I’m happy to report that, for the last 24 hours, everything has been working perfectly. I think you can mark my problem as “solved.”

As always, thanks again for your (and Dan’s & dspreadbury’s, etc.) help. In retrospect, I should have known where to look for such a setting, documented or not, but, not to overstate the obvious, this is a big program! But I think I’m finally past the steepest part of my learning curve, thanks in no small part to you guys.

I think you can mark my problem as “solved.”

You can do it yourself by going to Leo’s post #8 and clicking the ✓ Solution button.

not to overstate the obvious, this is a big program

It bears repeating!