Have to monitor every track i'm editing

With my new install of Cubase 12 pro from 11, I find that if I select a track and want to edit, I have to turn monitor on that track or I get nothing. The input on the instrument track is my midi keyboard. The tracks don’t have to have monitor on when playing back. I don’t remember that being the case with Cubase 11 Pro. Is it a setting that I have to change in my clean install of 12? I also remember there was a setting that when you selected a clip, it also selected the instrument. Anyone remember that setting?

For the first problem you described:

  1. Make sure Record Enable is ON.

  2. Make sure “MIDI Thru Active” is ticked (Preferences Window > MIDI page)

Is this maybe the setting you’re looking for? (Preferences window > Editing page)

1 Like

Beside what @alin89c suggested, are you sure that these two are ticked ? They do help, in this kind of case :

For the second issue, again, as @alin89c suggested :


Thank you a million times. That solved the problem. I also found under preferences, the option to turn on record for selected Midi and Audio tracks, so that saves me more extra clicking. Really appreciate you jumping in so quickly with the solution.

1 Like