Have you tried restarting your computer?

I’ve been looking and drooling at the PD one for ages, and i read in tears this topic:

Yup, the “Unavailability of CMC controllers” topic.
They’ve stopped building them. Before i could get my hands on them. Sadness.
But i find a store that has one in stock, the cleric is as devastated as i am to learn of the discontinuation.
I get it in the mailbox, i grab all the latest downloads (Tools for CMC / Firmware etc), and i install. I connect it.
Nothing. I try a few things, uninstall and reinstall. Nope. Firmware update? Forget about it, CMC device not connected.

In desparation i grab my PC (my production environment is a Mavericks mac) and install stuff there, hoping it’s an error with mavericks and the current firmware. I plug it in, and start the Firmware update. It runs just fine and now i have the latest and greatest firmware on it.

I plug it back into the Mac.
I try to add it to “Remote Devices” in Device Setup, but no such luck, just won’t bite.

I try un- and re-installing everything a few times (even grab the Yamaha USB midi drivers off of Yamaha’s site), nothing. I get the power light, pads light up when i press them, i can switch banks, but nothing on my Mac wants to admit it’s connected.

I try it on my PC again, works just fine.
Now i’m staring at my Mac in disbelief, i have no idea what to do next.
I’m a reasonably computer-savvy person, it’s an interest of mine, and i work as a software-developer. I should be able to figure this out.
I’ve been searching franticly up and down every thread on this forum suggesting anything in the direction of a CMC not working on Mavericks, nothing fits the bill.

I look at my Mac, and think to myself, “ok, i’ve tried everything, why not just restart it, and then go to the forum and ask for help…”, so i restart it.

My CMC PD is now working perfectly…

The “have you tried restarting your computer” cliché exists for a reason.