Having no gap between audio events

Hey guys just seeing if theres a way to be able to have the individual audio events exactly side by side without any time gap between them?
C13.0.4 - Macbook Pro M1 Max

Hi,

You can set the Grid to Snap to Events and then move them.

is there a shortccut where i can highlight all of them and it automatically aligns them hard up against eachother?

Hi,

I’m not aware of any.

Unfortunately, as far as I know, there is no function in Cubase that moves a bunch of events on a track in a way that the beginning of the next event follows directly to the end of the previous one, so that there lies no time gap in between them. Not even with the Project Logical Editor. Therefore I created a macro that can at least remove the gap between two events. Assigned to a key command and used several times in succession, it corresponds roughly to the function missed in Cubase. Maybe this can help you a bit.


Macro Remove gap between events

1 Like

thanks is pretty good!
only problem is it moves the start even to wherever the cursor is but does the job!
thanks alot

Put Cubase to Shuffle mode. Select all but the first event. Move them jsut a bit to the left - done. Takes 1 second.
grafik

7 Likes

@Johnny_Moneto Thanks, that’s even better and the actual solution! :+1:

1 Like

Hi,

To speed up this one: Shift + double-click the 2nd event.

3 Likes

Hi Martin,
This looks great to me. Very useful.
However: double click on track title works, but shift + double click on event does nothing at all.
Any ideas?
Windows 10 latest + Nuendo 13.0.40
Thank you.
Karel

Hi,

I’m not with Cubase at this moment. But if I’m not mistaken, Shift+double-click on an event should select the given event plus all following events.

Thank you.
I believe you, but on my system it does mot do anything.

So… One of the toool modifiers is Shift (to position the cursor where you click) and that was apparentely confusing the program.
After setting the modifier to (none) the shift+double click is working as promised.
Thank you for the great tip.
Regards,
K

Hi,

If you mean to disable the Snap temporarily, then this is done by the Ctrl/Cmd modifier by default.

oh nice!