Having problems triggering Groove Agent One from 3rd p app

I have Cubase 7.5, running on PC Windows 7. I have problems when I try to get the third party software to trigger Groove Agent One or any vat plugin.

I have Liquid Rhythm app and when I set it up to trigger Groove Agent One (midi input) I get no signal coming in. We get the signal on Liquid Rhythm channel working normally but when it’s routed to trigger Groove Agent One, we get no result.

The guy from Liquid Rhythm says he has no problem triggering Groove Agent One on his PC with Cubase 7.5 as well as on Mac. When I informed him that I have a problem on my system, he even tried remotely to recreate the same routing on my computer, but we got no result. He concluded it must be some setting on my Cubase preventing midi to trigger Groove Agent One. I use factory defaults, so this is strange.

Anyone has any idea what could be the solution?


OK, so this is over a year old now, but if anyone has the same problem, as I did, here’s what fixed it for me.

Turns out the 64 bit dll file (LiquidRhythm64.dll) on my windows 7 system had been installed into the Program Files (x86) 32 bit folder, causing the plugin to load in Bridged mode. This broke the midi out from Liquid Rhythm.

Once the dll had been moved into the correct 64 bit folder for VST plugins (and cubase restarted/plugins re-scanned) the midi out worked perfectly.