Having trouble with the tuplets popover in Dorico 5 (

In write mode, when I press the ; key, nothing happens. Mac mini, M2, OS 13.4


It works fine here. Mac mini M2 Pro, macOS 13.4.

Have you tried the various procedures which can often (but not always) clear a problem?

Restart Dorico;
Check the keyboard and language settings in System Preferences;
Open a different application (eg Word or TextEdit) and see if the key works in those;
Log out of your user account and back in ;
Restart the computer.

I started Dorico 5 and had this happen. This is the first instance of needing tuplets since installing Dorico 5.

After finding that Dorico 5 had this problem, I launched Dorico 4 and it has the same problem. Before the installation of Dorico 5 it used to recognize the “;” key for tuplets.

Word and TextEdit recognize the “;” key and the keyboard and language are both set to English (US).

I can’t restart the computer until I’ve finished an installation (HOOPUS) but I will do so and report back.

I’m not hopeful.

It might also be worth checking that it is still assigned to be the keystroke for tuplets in Preferences > Key Commands > Note Input > Create Tuplet.
I know that I have often made changes accidentally (or even deliberately) and then forgotten that I have done so and what I have done.

Have you changed (either deliberately or inadvertently) the input method language in macOS? If not, have you tried temporarily moving your user-specific key commands file out of the way so that Dorico is using the default set of shortcuts, and see whether that resolves the problem? That will at least tell us where the problem might lie.

I checked my key commands and they were as they should be (; for tuplets, : to cancel). In any case, I reset the key commands to the factory settings and now the tuplets popover is working. I’m unclear why the key commands weren’t working for Dorico 4 though… do they share a file for key commands?

The installer looks for custom settings in the previous installation, so your custom key commands get copied over automatically.

Thanks, Mark. How does that explain that the Dorico 5 key commands for tuplets looked correct but were non-functional until the reset? I’m mystified but at least with the reset things are working correctly. I did have to re-do several of my custom key commands though.

I dunno. I’d have to see your (previous) key commands file to get an idea what happened.