Headers on instrument part does not display accidental

Headers on instrument parts do not display accidentals. For example, it displays “Clarinet (B Flat)” not “Clarinet in Bb” with the accidental. Why is this and how do I fix it so it displays and prints correctly for all instruments in different keys?


Two ways of doing it:

  1. Edit the Page Templates in the Default Part Page Template Set so that, in the top left corner of the First Page Template and the header of the Default Page Templat it uses {@StaffLabelsFull@} rather than {@LayoutName@}.
  2. Double-click on the layout name in the right panel of Setup mode and type “Clarinet in B {@flat@}”.

Thanks so much! How do I have the same font size for all headers? Also, I want “Clarinet in B” to be bold and the flat regular. How do I do that?

Instrument part headers, that is.

I wonder why Dorico doesn’t do this by default? :thinking:

If you want a change to something like a header or footer to apply to all of your layouts, you need to edit the corresponding page template. Open one of your part layouts, then go to Engrave mode, and on the right-hand side, open the Page Templates section on the right-hand side, then double-click the Default page template to edit it. For more detailed help with managing page templates, you might find this set of video tutorials helpful:

(Note that we changed the name “master pages” to “page templates” in Dorico 4, and these videos pre-date that change, but the functionality is the same.)

Thanks, Daniel. This is helpful, but the header font sizes are not the same in all parts. Also, I want “Clarinet in B” to be bold and the flat regular. How do I do that? I’ve uploaded the file.
Schadenfreude.dorico (1.8 MB)

The problem is you edited each page directly instead of the Page Template. Every page now has an override which is going to cause you all kinds of problems.

1 Like

I’ve attempted to fix your Project. I tested a regular flat symbol and a bold and I can’t see any difference between the two. So, I am using full staff labels as is.

Schadenfreude2.dorico (1.8 MB)

A few notes on what I did.

  • Moved your local edits into the Page Templates.
  • If you want all the Instrument names on the parts in bold, edit the Layout name paragraph style in Library > Paragraph styles.
  • I created a Subtitle paragraph style for your subtitle and added it to your Page Template.
  • Turned off Flow Headers in your score as it did not have any. The parts still had them so I left them.
  • To get rid of the Flow 1 in the header on 2nd page onwards, I put a space in that field in the Project Info dialog. I could have edited it out of the Page Template as another way.

Thank you so much for your help, Craig!! Question: How do I make all part headers the same font size, including making them bold or italic? When I edit Layout name in Library > Paragraph styles it changes only the header on the first page of the part, not subsequent pages.

The subsequent headers use the Header Paragraph style.
To find out which style is being used, edit the Page Template and double click the text box. The text format dialog will tell you. See pic below.