Headphones not working with surface pro 4

Hello. I am running a trial version of Cubase elements with a surface pro 4. The surface headphones are working correctly with everything except Cubase. I have enabled a stereo output bus for my project and think I have everything set up correctly but no sound. When I unplug the headphones I can hear the sound coming out of the surface’s own little speakers. Please can you help.
THank you.

I think the SP4 uses the same onboard Realtek soundcard that the SP3 does.
Windows sees them speakers and headphones as 2 separate devices.
Make sure you have the headphones set as the default in the Windows control panel sound settings.

If you are using ASIO4All, then you need to enable the headphone output, not the speaker output.
If you are using the Steinberg Generic ASIO driver, you need to go into Device Setup in Cubase and enable the headphone out.
Generic ASIO.JPG

Thank you Richlum.
I did as you suggested: set headphones as default output. However, when I went into Cubase it would not allow me the option of selecting headphones. I will try to attach a screenshot so you can see. I seem to be stuck… Any ideas on what to try next? Thank you.
Screenshot (4).png
Screenshot (6).png
Screenshot (5).png

Did you set up the headphones in the ASIO driver panel (see Rich’s picture)? You should be able to access that panel under Devices -> Settings… VST Audio System… “Control Panel?”

Hi Jaslan. That is precisely my issue. It only offers me the option of speakers or “not connected” in the ASIO setup box. I am at a loss to figure out how to get it to include the headphones. :frowning:

Can you please post a shot of your “ASIO Setup Box”?

I thought I already did. Please see screenshot 5 in my previous post…

You posted shots of VST Connections and Windows device settings but not ASIO device settings in Cubase.
Refer to Rich’s screenshot and my first post.

Ah. Apologies Jaslan. Hopefully this should be the one you want:
Screenshot (8).png

Yes. That is the one i wanted to see. Unfortunately, i dont see any thing there to advise. The only other thing i can suggest is, in the Windows Sound Device Settings (your shot 4), click on configure and properties and see what options are there.

This may mean the headphones do not come ready for ASIO. Which is probably not a showstopper, you just may have to download ASIO4ALL (just google it) and hopefully it can configure the headphones for ASIO use.

I think you need to plug in the headphones for the audio-driver to be enabled. Then you can configure it in the Generic low latency driver setup, and then you can start Cubase. I remember Molten Music talking about the crazy way Surface handled the Headphone output.
**
https://www.youtube.com/channel/UCzLl8NF-hiP2HMq5dL2NQOQ

Thank you so much for all your help Jaslan, Peakae & Richlum. Incredibly (or so it seems to me…) it is now actually working! :smiley: You were right about needing to plug the headphones in first, Peakae. I had tried that previously - ie. plugging in before starting Cubase, but that wasn’t enough. This time I completely turned off the computer, plugged in the headphones, then restarted Cubase and reset the devices (was quite fiddly - it didn’t seem to want to let me do this… :wink: )

Anyways touch wood all is well now. Shame it took so long though - in the meantime I ended up having to do everything on cubasis on my ipad… I enclose some screenshots of what I have just done in case anyone else is also struggling with this:
Screenshot (13).png
Screenshot (12).png
Screenshot (11).png