Helix ASIO not shown in Cubase AI 10 (anymore)


Since I got my Helix Stomp, I’ve had no problems using it as an audio interface with Cubase AI 10… Until recently. It just doesn’t show up anymore on VST audio system selection. Even Audacity chooses my Stomp automatically as a recording device and works just fine. Any ideas would be greatly appreciated!

Does Audacity use ASIO drivers ?

either way I’d probably try reinstalling the Helix stomp drivers

Well, I looked it up and turns out Audacity doesn’t even use ASIO by default. :grin: But I’ve already tried reinstalling both Helix driver and Cubase.

do you have anything else that uses ASIO drivers …HX edit ? just to check .

If the driver has ‘disappeared’ then that’s the problem - not a cubase problem.

don’t just do a reinstall over the top do this:

1 - uninstall the HX Stomp driver via your Windows Add/Remove software
2 - reinstall HX Edit and check both Helix driver options, ASIO and Win-USB

So the drivers had derped somehow. I uninstalled HX Edit and all the drivers completely and installed them again. Works now! Thanks :smile:

1 Like