Help a Newbie Out - Mixdown Having Slowed Audio Playback

Greetings all! Not sure if this is the right place to post this. Very new to both Cubase Pro & audio engineering in general (amateur YouTube musician.) I’ve seen that this question has been asked many times over the years & I’m sure it’s something I’m doing (or not doing) so hoping to figure out what. My sound card is 48kHz. I made the mistake of doing a project in the default 44.1kHz record format.
Every time I do a mixdown, seemingly regardless of what sample rate I choose, or whether I choose, Wav, Mp3 etc. the playback is slowed down. When I attempt to change the record format in the project from 44.1 to 48, all of the instruments are again slowed down and everything is moved out of sync. I have backups of everything in the pool and have attempted multiple tests & solutions that so far have all had the same result. To make things stranger, if I were to try and record or share my screen with apps such as OBS or Discord, the audio playback for Cubase will not be picked up. I can clearly hear the things I’ve been working on so trying to figure out where it’s all going pear shaped. I’ve done mixdowns in the past that were fine so not sure why it’s an issue this time around.

Did you try to put your sound card in 44.1kHz before exporting and not change the format in Cubase?

Greetings! Unfortunately, it seems my sound card only has 48k (studio) or 48k (dvd) as options. Temporarily I got around the issue by just taking the slowed mixdown and manually speeding it up by 110% in my video editor to get it to sound right. Would still like to figure this out for future reference though.

I have the same exact issue with my Universal Audio Volt 276 and Cubase Pro 12. All mixes are pitched a Whole town down and slower no matter what bitrate or kHz I choose. The Volt is not changeable at 48khz. Never had this issue with any of my former Audio interfaces