Help! Adding transformer on many tracks

Hi guys. I have my template all set up with correct midi channels. I need to add a transformer on every midi track. Saving one track as a present and loading this on each track will destroy my midi channel routings (but thankfully not the output routing). Can I edit the trackpreset.xml and remove the channel info so the current midi channel info is preserved?

Otherwise, does anyone have any tips for quickly adding a transformer to hundreds of tracks? It’s a shame I can’t save the midi send info as a present.


Cubase 10. 5 on windows 10

I had a similar problem.
I tried opening the mixer and adding the transformer to the Midi tracks there, both by Qlinking and also by simple copy and paste - both were quicker but ended up with a permanently linked plugin - if I changed one parameter they all changed (even if I unlinked the tracks - not sure if this is by design or a bug).
In the end I bit the bullet and did them track by track (700 tracks).
I found each instance took ages to load - I’m never going to get that time back!


OK, cheers anyway

Its not clear what you are trying to acheive.

To set transformers for all midi tracks then set the input transformer (top right of inspector) to Global, from there you can make 4 separate rules for all channels which have the inout transformer turned on.(also set to global)

You also mentioned midi sends as well. These are not robust at all (especially with Kontakt) and limited to 4. There are alternative third party solutions to using sends for midi tracks.

Each midi track needs a transformer in the midi send. Each track needs to send out out a different midi cc on selection (e.g. Channel 3, cc 45, value 125). Each track must have a unique address.

I hope that’s a bit clearer! Any ideas?

Deactivate “Open Effect Editor after Loading it” in preferences to avoid multiple open effect editor windows. Select all tracks. Activate Q-Link. Add transformer to one of the tracks.

Yes! That works! Thank you so much. Never thought to do it in the mixer view, and now I learnt what q link does!

Just check that the various Transformer instances don’t all update together when you change one. Even with link turned off as I seem to remember that was happening for me but may now be fixed

Actually, I seem to be having the opposite problem…with q-link activated, I update one transformer’s midi send channel, but they don’t all update. Is this expected behaviour? If so, now I’m wondering if it is easier to just copy them by dragging one that is all set up to the other tracks from the mixer window…