HELP! audio dropout and lot of CPU audio processing - MacBook Pro

Hello to everyone

I need help about my problem that I’m not able to solve.
Hardware:
MacbookPro (13inc, 2017 w/two Tunderbolt 3 ports) 2,3Ghz Intel core i5 dual core, 8Gb Ram.
Mac formatted, macOS Monterey 12.1
RME UCX connected via usb to an USBc adapter/hub.
Cubase 11.0.41 clean installed
Thrd part plugins installed and used for now: Fabfilter plugs, SSL Native (FlexRev, Channel V2 and Bus Comp V2), all updated to latest version.

I’m experimenting super charged CPU load and audio dropout on a project that manage only 5 mono tracks with an SSL channel on every track, only a FlexVerb instance, an SSL Bus Comp on master and a Fabfilter L2.

This is a very strange experience for me because I work on other Macs without problem on more busy project w/a lot of plugs processing with a 128buffer size on audio card setting.

I’ve read the Steinberg article for Mac optimisation but the advices doesn’t works for me.
Any suggestion? Please help me, on the same machine I’ve tried working with the same mixing demo in Logic without problem.
Thanks to all of you that want try to help me.

Update:
trying to disable all plugins, in stop mode Cubase give me this processing:

I have the same issue and I found that is because media bay is continuously scan for files. You can try to see if you have the same issue by filtering files on media bay. Did not find any solutions, because I cannot create a database on the main Machintosh HD disk

Id bet its the bus comp thats causing it. I have a 2020 Mac mini i7, and when I bought the bus comp during their last sale I tried it in Logic Pro, which is arguably more optimized for the Mac than Cubase is (just moved back to Cubase 2 months ago). The bus comp takes an entire core of my CPU all on its own and is at the top if I have oversampling on. All it takes is for that one plugin to spike over and it will take down your whole mix. After I saw that, I went right back to using either the Waves SSL bus comp or the Brainworx Townhouse. Both of those barely hit 20% of one core when they’re really working.

What about a bigger buffer such as 512, 1024?

it help, as expected, but is a workaround. Thanks anyway :wink:

Yes, the oversampling eat the cpu, I noticed that, in my case, turning it off is not the solution to the five audio track project on a “modern” macbook.

I suspect that I need to know how to make a Macbook optimisation, the same project on a more dated iMac is more cpu friendly.

Hmm ok. So, just to help us understand, why do you need such a low buffer setting of 128? Are you working with lots of outboard gear?

Virtual instrument recording and outboard instruments

Maybe that is the reason I experience the same problems on my Win10 - i7 PC. Working with Cubase ain’t much fun anymore lately. Constant overloads en audio dropout even when opening the Meldaproduction Tuner!