Help creating macro for enabling/disabling MIDI tracks in VEPro

Hi,

I’m in the process of creating a film scoring template where all of my instruments are hosted in Vienna Ensemble Pro and disabled (unloaded from ram) by default. I’m trying to set up a touchscreen interface using Lemur to remotely enable/disable the instruments in VEPro.

I’d like the following to happen

  1. Press an enable / disable button on Lemur

  2. Selected MIDI track in Cubase is toggled from disabled to enabled. This would serve as a visual guide to what is enabled/disabled in VEPro

  3. MIDI CC message is sent out to VEPro which triggers the enabling/disabling of the instrument within VEPro.

How would I go about creating a generic remote / macro / PLE preset to do this? In the first instance I can’t find a key command for enabling/disabling MIDI tracks…

I am looking for the same thing, but without Lemur. Ie I want to create a macro to enable disabled VE PRO channels on midi activity. I am new to the Logical editor. Thanks Max for outlining the steps.

I don’t use VEPro so can’t comment on that part but the command to enable or disable a Track is listed in the key commands as “Disable/Enable Track”, I use it all the time.

Katie have you had any success achieving this? I’m also happy to skip the lemur part. How does one create a macro that first toggles enable/disable on a selected track and then sends out a MIDI CC message?

If you mean you want to enable a track when the track receives midi, this is not possible in Cubase.

Hi Max, I have not succeeded in using Logical Editor for anything, but I have done this:
-Created a Generic Remote for a pedal, set on my controller keyboard to send Cc93 to Selected track, flags Pushbutton, Toggle
-Preferences: selected track is armed
-Each instrument channel in VEPro is automated to Disable/Enable on receiving CC93

It’s working for HS and VSL libraries but creates problems in Garritan. Still working on that.
Have not found a way to add Disable Track, maybe I can add a 2nd row for the same pedal CC93 in the lower pane of the Generic Remote.

Oh, I remember now…I could not find the command to Disable in the Generic Remote setup.

The command to Disable/Enable tracks is under Command>Audio>Disable/Enable Track in the Generic Remote. :wink:

Looking at this again - still cannot see a way to Disable track via Generic Remote.
Also - since my controller is to operate on any selected MIDI track, I have done nothing with the drop-down to the right of the lower pane, which defaults to the first bank of VSTis with later banks avail in menu, ie “VST 1-16”
Do I need to create a control set up for each bank?
See below screenshot of my Generic Remote for this pedal control- any comments welcome, it took a couple of weeks trial and error to get this far…

Re png in post above:
By the way, I don’t really want “Mute” as an action, as there may be tracks muted for various reasons, and it is no help in this situation. But I have to choose some action. I tried Selected but that deselects and thus disarms the track, which is unwanted when ENABLING the VEP instrument channel.

FURTHER EDIT/UPDATE- in fact this MUTE is operating unpredictably on GPO as plugin directly to Cubase. Recorded values suggest pedal is recording continuous values, other than 0 or 127, and I can’t clarify what they are doing as they are not muting playback of recording. But they did mute when playing.

I am trying this with GPO as direct plug in Cubase not as plug in to VEP, as with this controller setup and automation in VEP, VEP freezes with a hanging GPO sample upload at Enable. The other libraries enable/disable satisfactorily, though a little laggy on my system.

Not sure you saw my post above,

In case it was not clear, have a look at the attached animated gif.
GenRemote.gif

I tried removing the 2nd line. Same result (after Apply).

With the Generic Remote set up of one line only, “Selected” , and the Value/Action field is set to “Selected”, [see attached image], with VSL or HSO as plug ins in VEP, the selected and armed Cubase track deselects and disarms, and VEP channel disables.

I just can’t achieve this in Garritan due to the sample upload hanging.

Steve,
thanks for your post just seen, I had not seen that gif. I will study it now! There’s a lot there unfamiliar to me…hopefully I’ll get it:)
PS I will also try again to get notified of posts to this thread.

Can’t seem to attach the new png. I get a lot of graphic anomalies when trying to post in this forum, and my finder/typing misbehaves, so I often have to abandon it. Will try again to attach.

Npe, just getting a green line (was red last time) off to the right of the Full Editor window “STATUS” column, then a warning icon in the column. Anyway, I’ll work on your gif Steve, thanks again.

Thanks Steve, I’'ve just tried this command in a 2nd line in the Generic Remote. Great to know where it is - I didn’t think of Audio!
However, I exported the new setup immediately and imported, but the 2nd line was Not Assigned when imported.
I created it again, hit Apply, and tried it on a track.
The track deselected but did not disable. I do not have VEP running at present but I would not expect that to prevent the Track Disable happening?

EDIT- maybe because I still have Action/Selectedin the first row. What value can I replace that with?

I deduced that Command/Audio/Disable trk may apply only to an audio track, which of course is not selected in this scenario.
I found Command/MIDI/Disable trk, (which is not in Key Commands but is in the Context menu on the track controls itsel, and also in the GR) but though VEP Channel disable continues to work, the MIDI track is not disabled, only deselected. So there is no visual feedback in Cubase re which instruments are disabled.

Another problem slowing this work down is that exported GR setups are often changed when reimported. I’ve found it necessary to check the Studio Setup/Generic Remote every time I open a Cubase Project and from time to time after making changes in Studio Setup.

I’m sorry you’re having so much trouble with this, but the question remains, did you follow the steps I gave you in the gif?

Thanks Steve, I’ll just check again, I didn’t realise it was steps, I just saw one. So it’s a movie…great

Well I believe so, but check me…I created a single line, Controller- Command-Audio-DisableEnable track, Apply, OK. I ignored the lines below that say strip/slot etc. That’s all I see in the gif. That did not affect the MIDI channel selected and armed to receive the controller message.

I did not type as you did, I just selected from the available options.

When I did the same but using MIDI instead of AUDIO in Channel column, the result was the same. The armed MIDI track became deselected, but not Disabled.

To check I remember what a Disabled MIDI channel looks like, I chose Disable from the track control context menu of the MIDI track. The track controls become dim and buttons inaccessible.

This is not the case when I use the command in the gif.Should that command disable a MIDI track?

But I just did it again and it is now disabling. This time I left an additional unassigned row below the one in use. Before I had no rows below.