[help] cubase 12 not snapping when pasting

Until today, what i could do was hold ctrl+alt+shift, click and hold a sample, and drag is to copy/paste. If i did this while snap was on, the new copy of the sample would snap to whatever (grid/grid relative). Now suddenly it’s behaving as if snap is always turned off. Anybody else encounter this problem, and/or know how to fix it?

Hi and welcome to the forum,

Of you didn’t change the modifiers preferences, by default you should hold just Alt. If you hold Ctrl, you disable the Snap temporarily. Of you hold Shift (+Alt) you make shared copy.

1 Like

Did you possbly turn on ‘Snap To Zero Crossing’?

1 Like

Yep that did it (only alt, not even poop+alt), thanks for your help mate