Help! Cubase 8 Artist FX Channel to Group Track Routing etc.

Hi All,

I’m probably being stupid (I only recently upgraded from 5 to 8), and no doubt someone will point that out ( :smiley: ), but I can’t seem to route my FX channels to a group track in Cubase Artist 8. I.e. the group tracks I have created don’t appear as an output option for the FX channel.

I’ve seen other similar posts in which people advise to make sure that the sends in the group track aren’t assigned to the FX channels as Cubase won’t allow feedback loops, but they aren’t (they are all assigned ‘no buss’) and Cubase still won’t show the group tracks as outputs in FX channels.

As part of this, I notice that I also don’t have sends on my FX channels (although the manual shows there should be).

I also don’t have a Group/FX tab on my VST Connections dialogue?!

Have I set up Cubase fundamentally wrong in some way?! Ha ha!


There are Inputs and Outputs tabs only in VST COnnections of Cubase Artist. That’s correct.

And It’s correct, you cannot route FX to Group and Group to FX in Cubase Artist. This is Cubase Pro feature only. The only one way, how to do this is right-click to the FX Channel in MixConsole and select Add Group Channel to “currently selected track”.


Thanks for your help. Very much appreciated.

That explains it then. You know this is the first time I’ve bought a cut down version of Cubase! I should have just stuck with the pro version :smiley:

Simple workaround…use a group track as your FX track and you can route group to group…and you get sends.

Hi,Following the work around, used a group track as my FX track and routed group to group…Now I want to record the Final Mix on to a Stereo Audio Track . Could you tell me the possible work around in(Cubase 8 elements) pls?

Can’t you just use export audio mixdown with import to project ticked?

YEs… i tried audio mix down option and it worked for me. But the Volume level is very low - I’ve loaded Alicia Keys Piano on to Kontakt Player as a VST instrument . The Master Level is 0. The Group Levels are also set to 0. Any idea how to get the right Level ? I tried Halion Sonic SE2 too… its sounding very low but when I drag a drum loop from the Loop Browser its sounding good. Its just that I am having issues with the VST instruments now.

I’m not fully understanding your routing or reason for it…what are you trying to achieve by routing from groups to groups exactly?

If your instrument is set at unity and so are the group and master the mixdown should come back in at exactly the same level. If not you’ve probably set something wrong.

Dear Grim, Thank you so much for your replies. I checked the Signal path and corrected it everything is working fine now. :slight_smile: