HELP, I can play midi but suddenly not record anything

I have the strangest problem suddenly in Cubase 7. I can play my keyboard fine and I hear the samples and even see the midi fader moving on cubase, but when I hit record, Cubase doesn’t record any notes I play with my keyboard!!

I am using M-Audio Keystation Pro 88 (I did factory reset but no help), it used to work fine, but suddenly this problem appeared. I have installed Korg nanoPAD2 recently, I don’t know if this has anything to do with it? The strangest thing is that as I hit record, Cubase records my nanoPAD2 fine, but nothing happens when I hit the keyboard (even tho I hear the samples).

Any ideas what might be causing this??

It seems that I can get my midi keyboard to record if I tick “Use System Timestamp for ‘DirectMusic’ Inputs” in the Device Setup -> Midi Port Setup. The Korg nanoPAD still works fine without this setting.

I didn’t have to use that setting before. Any solutions to this?

Ok I managed to get Cubase to record MIDI by switching between different ASIO drivers (and then coming back to the one of my audio interface) - now Cubase records midi fine with or without the “use System Timestamp” setting.

Now my final question is that is there any reason to use the “System Timestamp” setting if I can record midi without it?

why are you switching asio drivers , surely you should just be selecting the input you want on the inspector for that channel on the project page ?

Well, I have two audio interfaces. Now I found out after testing that when I have only my main Interface turned on (Prism Orpheus via Firewire) I have to use the “System Timestamp” setting to record midi with my M-Audio Keystation. If I have also RME UCX (via USB) turned on, then I don’t have to use the “Timestamp” setting to record midi - even if I would use Prism ASIO Drivers. Weird…

Strange thing also is that my Korg nanoPAD works fine without the Timestamp setting, even with just my Orpheus turned on (I guess it is because it is connected via Windows MIDI instead of DirectMusic).

Are they all connected to the same controller?

Or rather, are they all connected to the FW and USB ports on the motherboard or the same card?

Yes they are all connected to the same motherboard.

Just something to try out…

I assuming you are using the RMX as main audio device, otherwise replace “RMX” with “Prism”.

Take a look at the device setup.
Do all (RMX, controller and keyboard) have the “all MIDI inputs” checked?
If so - try unchecking “all MIDI inputs” for the controller.
Do the same for the RMX MIDI in- and outputs (I assume you do not use them).
Make sure to configure the controller (also) as a remote device in the device setup.

It can also be helpful to configure each device to have a separate MIDI channel (example: Keyboard channel 1 and controller channel 2). In that case you make sure no “overlap” takes place.

Using more then one audio device complicate things, because both (RMX and Prism) have a MIDI output/input that can interfere with the controllers (keyboard and nanopad). Make sure you have everything configured well in the device setup. Even better - If you do not use the MIDI I/O on both audio devices remove the check next to “visible” in the device setup. This makes sure only the Keystation an nanopad are used as MIDI devices.

In Cubase you can only use one audio interface at the time - this is defined by the selected ASIO driver in the Device Setup -> VST Audio System.