HELP!!!I can't submit a Support ticket- CUBASE 8.5

Hello. I need to speak to someone from Steinburg US support team but when I fill out the support page online it won’t let me put Cubase in as my "Registered and supported product’ which is a mandatory field. They have put a check mark there and I can’t put anything there… So my request form won’t submit because i can’t fill in this field.
I don’t understand. I haven’t even had cubase for a year and i keep getting error messages saying that my eLicenser is invalid. I did an update a week or so ago and now I’m screwed. I paid a lot of money for cubase and this is unacceptable. Worse, I can’t contact support because ‘MySteinburg’ won’t allow me to put my product information in a mandatory field. They don’t have phone support so I have no idea what to do… I’m so frustrated and only want someone from support to contact me.
my email is: [email address deleted] if someone can help me with this
Kind regards,

You really shouldn’t put your email address in a post, you are leaving yourself open to a ton of spam.

Also replies to questions need to be kept on the forum (as the answers could benefit other users).

Hopefully one of the Steinberg folks can help you out.

Yep…first thing you need to do is remove your email from the first post.

Then you need to tell us more clearly your problem. What o/s are you on? What does the error message say exactly? What update did you do?

You’ll likely get an answer from another user here that will solve your problem way quicker than from support. Try it!

Hi Kimberlyn,

Have you tried to submit your support request through an alternate browser? Please do so if you haven’t already. If it still will not submit, please send your request through our Product Info Box:

Be sure to include a detailed description of the error you’re receiving as well as the OS that you’re running.

Thank you.

I went ahead and deleted that email address.

Hello. I used a different browser but still couldn’t submit a ticket to request support. On the Contact support ticket down where it says: Choose Product, under Registered and supported Product, it won’t let me choose anything… It keeps automatically giving me a checkmark there so when I submit a request, it won’t go through because it’s a ‘required feild’ and it won’t allow me to choose anything…
So I’m Using Cubase 8.5., I Mac version 10.10.5 (Yosemite) 8 GB memory…
I purchased it 10 months ago through Guitar Center. I have never had a problem with my eLiscenser before.
I searched some topics in the forum and other people were having similar issues becuase of an update.
I also have an Access Virus T1 that I have been using with Cubase the entire time and have never gotten error messages before either.
I think it could have been after my update but ever since, when I start up Cubase I get the following messages…
eLicenser Control - Error
Application ‘VST Connect Pro’ has caused the
following error:
eLicenser(s) contain(s) no valid license for this
-For troubleshooting information click
-Click to view available licenses.
-Connect a valid eLicenser and click
-Click to abort

…I did all the above options and still get the same message everytime I start Cubase… I even tried removing the eLicenser and putting it back in… I really need to get in touch with technical support but as you know, I can’t submit a ticket…
I am also getting this message now, which I imaging has to do with my Virus:

This input/output configuration in not supported.
You have chosen an input/output configuration which allows for side chain inputs. This sequencer host software does not fully support audio inputs for software instruments.

Sorry about posting my email… I was hoping maybe someone with technical support would just send me an email and contact me that way… I didn’t even think about spam or anything because I was desperate. I would love to have a solution to these problems. Thank you so much for your help.
Kind regareds,

Make sure you have the latest version elicenser installed

The error message that you have posted is for VST connect Pro and not for Cubase.
Once you OK through these messages I assume Cubase runs normally afterwards?

Maybe you somehow managed to load the trial version…uninstall it and the messages should go away. Or have you bought VST Connect Pro too??

Hi Kimberlyn,

First, please go to Download and install the latest version of the eLicenser Control Center.

VST Connect Pro is a separate purchase that is not included with Cubase Pro 8.5, VST Connect SE is the version that is included. Did you purchase the add-on?

If not, you most likely downloaded it by mistake. You will need to remove it from your system. To do so, please do the following:

Delete the folder, go to:

Library->Audio->Plug-Ins->VST3->Steinberg->VST Connect Pro

Delete the component:

Library->Application Support->Steinberg->Components->Vstconnectpro.bundle

Per my last post, you can also contact support through the Product Info Box:

This is done through e-mail and does not require you to fill out an online form.

If you are still experiencing difficulty, please submit a request via the Product Info Box.

Thank you.

Hello there… I’m not sure if I purchased it or not… i went to:Library->Application Support->Steinberg->Components->Vst connect PRO->
under that I have: VST Connect PRO.vst3
not, Vstconnectpro.bundle
and the file is from March 5, 2016…
Does this mean I purchased it?
or is it a trail version… I literally have purchased so many things I am at a loss remembering…
I did send a message to product support alerting them that I needed to be in contact with tech support. I did that a couple hours ago.
So should I delete the file I have? VST Connect PRO.vst3?
Kind regards,

Hi there. Did you ever manage to resolve the initial problem of not being able to submit a support ticket? I have the exact same issue. When I try to submit the request I’m told I need to chose a product, yet I have no option to choose from…

my freshly installed version of Cubase (on a freshly installed OS), is crashing every time I try to open an audio track and it’s starting to drive me a little mad…

If it can help I have a 2018 macbook pro on which I’m running high sierra.