[Help] Inter-App Audio Not Recording effect

I must be doing something wrong here. I am running my bass though an inter-app audio effect. I tried it as an insert, as well as a send effect. But when I play back the audio, it is a dry signal. The effect is audible while recording but not after recorded. What am I doing wrong?

Hi Future Aztec,

What happens if you assign the effect on an existing track afterwards?

Are you able to provide us with a short clip, that visualises the problem?
If so, please share the download link via private message.

Best,
Lars

Well I tried all night to produce a clip but when I used on screen recording 1. It wouldn’t start recording 2. It wouldn’t stop recording 3. The sound was so out of sync that the video didn’t make sense 3. When I tried to watch it to check it iPhoto kept wanting to play it only on Apple TV – I don’t own Apple TV 4. It recorded it but never saved it…etc…etc… I did several hard resets and in the end after scouring the internet for solutions to these problems could not produce a video.

Maybe I will get interested again at some point. I just opened a pandoras box of bugs – as happens from time to time with computers. Every possible solution becomes some new problem. I am sure you have been there…

I have another issue. The freeze track with the IAAP on it does not reflect how the track sounds unfrozen.

iPad Mini 4
iOS 11.3
Cubasis 2.4
Audulus 3 Inter-app audio insert effect

Hi FutureAztec,

Thanks for your message.

A simple clip taken via your mobile phone would work here.
Please make sure to keep the instrument app vendor informed about the issues as well.

On a side note, it seems Apple has put their focus on their newer Audio Unit format (instead of IAA).
Therefore it might be possible, that the issue(s) cannot be solved in the end.

Best,
Lars

Updated my iPad Pro to iOS 11.3 now Cubasis 2 app crashes right on the startup. Any help Lars?

Hi bishnugupta,

Should not be the case.

Here are the steps how to activate the Cubasis reset:

  • Open the iPad “Settings”
  • Scroll down left column until you see the Cubasis app icon
  • Tap “Cubasis” app icon
  • Enable “Load empty project on next app launch” option in the right column

Hope that helps,

Lars

When I have sampletank connected via the inter-app function for a track I use a midi keyboard to record live onto the cubasis track, I’d like to do that on multiple tracks changing the sound each time and recording each onto a track in cubasis. I apologize but I am new to midi recording. When I set up an audio track with sampletank as the input, it seems to only accept sampletank with a mid track set up and then it looks like sampletank will be locked into that track. Therefore if I create another midi track it tells me sampletank is already being used. I am concerned that even though there are many sounds I can use on sampletank you can’t use it on more than one track in cubasis. Thanks!


Zain,
Web Developer
https://tutuappvip.co/
http://eidmubarak16.com/9appsapk/

Hi zainali123,

Thanks for your message.

Apple’s Inter-App Audio format is limited to load the same app once.
Therefore it is not possible to use or load the same app on several tracks.

Here is a tutorial regarding Inter-App Audio in Cubasis: https://www.youtube.com/watch?v=sDfZvwPrkTo
Please have a look at our forum article also, that explains the limitations of inter-app audio: https://www.steinberg.net/forums/viewtopic.php?t=104551

In this regard, it might be worth to take a look at Apple’s Audio Unit format, which comes with much less limitations (and can be seen as the successor of IAA more or less). Audio Unit support is feature at around 6:45 minutes in the following tutorial: https://youtu.be/TNZ_WeD7Z-4

Please note that we’ve implemented both formats quite a while ago, which is the reason why Cubasis might look different in those tutorials.
Alongside, the app has been updated with many new features and maintenance topics since then.

Hope that helps.

Best,
Lars