Help me! keyboard msb lsb

Hi Guys!
I can not set the sound change of my modx.
My actions:

  • Connection and check the modx port (OK)
  • I create a layer and hook the modx door,
  • I set MSB C00 and C32 LSB, and then in the program change box I put the number.
    Unfortunately it doesn’t change my sound. Where am I wrong? Thank you

That should work. Can you check with another device? For instance, temporarily use Halion Sonic SE as the Layer Instrument instead of your ModX output. Open Halion Sonic SE, in Options/Global/Program Changes select “GM Midi”, leave the Editor open, and set Midi Program Change in the Layer, and check how the first slot changes.
We will try to test with a ModX when possible.

I also tried with fantom 06, Montage, and Jupiter X and the sound change never works. It works perfectly as master, in the sense that if I use for example the Montage or Modx or any other as master using the vst the midi messages arrive, I think the problem is that VSTLive does not send the MSB LSBs and the program changes.

Anche con la versione 1.1.73 si comporta esattamente come segnalato. Non invia messaggi msb lsb alle tastiere per il cambio suoni

Sorry, Google Translate makes no sense out of this.

Watch the MIDI Monitor output at the bottom.

Also note the convention problem that some plugins and/or DAWs (incl. VST Live Layer PGM CHG item) count Program Change starting at 1 (one), but MIDI data always starts at 0 (zero).
So try again setting PGM CHG to 37 instead.
If that doesn’t work either, there must be a timing problem with the ModX. I connected physical MIDI In to physical MIDI Out of the URC to have the Midi Monitor show what is actually put out. Cannot find anything wrong with it, sorry. But of course we’ll check with the ModX.

Ok but the problem is not only with the modx it does it with all the keyboards in my possession for this I say not to investigate only on modx, the problem occurs with fantom, with fantom 0, with jupiter x, with Montage, etc… The problem is that I can’t figure out why even if I set msb correctly, lsb and program change doesn’t change anything on any keyboard. I also used the function directly from the LAYER menu but it still doesn’t send the sound change. For example the same codes on other software changes the sound smoothly. Same settings same machine same links, I just use other platform and it works fine

What you mean by that?

Also, did you check the Program Change +1 problem?
Are all of your tested synths hardware? All USB, or also MIDI? Asking because then you could at least apply the same test as described (connect MIDI In to MIDI Out and watch MIDI Monitor).

I used the function from the layer menu, instead of directly in the layer by expanding the lower part and entering the msb lsb codes. On +1 yes, no problem, because regardless of the “correct” sound, I put any code on program change and it never changes the sound on my keyboards. I 've only usb midi

You cannot enter Bank Select Lsb/Msb codes anymore in the Layer, only in menu Layer/Layer Controller Map. In the Layer view, you can only set the Program Change number. When PGM CHG is sent, Bank Select MSB/LSB are automatically sent along with it.

Oh, maybe you mean like in the picture? Don’t do that! These controls are supposed to be used for cutoff etc.
Set MSB and LSB in Layer/Layer Controller Map. These controls are not meant to be used for that.
As said before, when a Program Change is sent (when you change it, or when the Layer Part gets selected), Bank select MSB and LSB from the Controller Map are sent along with it automatically. Applying additional Controllers in the Layer Quick Controls will probably confuse the synth.


Screenshot 2023-05-15 alle (1.5 MB)
I removed the codes from the layers as you suggested and inserted the codes from the layer menu. Unfortunately nothing changes :frowning: I don’t understand where I’m wrong… upload image zip

Open MIDI MONITOR > Select MODX > Select LAYER MODX > Midi monitor empty

But…nothing is connected to the Layer Instrument??


No ! I use the keyboard sounds associated with the song, if I add a VST it plays that too, and in any case even adding it doesn’t change the sounds to my modx

I suggest you should take very small steps.
First, create a new project, configure one Layer and see if it works.
And let us know what you want to acheive. If you want the ModX to switch programs, it needs to be set as the output (Instrument) of the Layer, so you need to configure a MIDI Output Connection in Devices/Connections that is connected to the Modx.
Then i suspect you expect the Layer to switch pgm chg, bank select etc when it receives Input from the Modx; it will not! It will output those when the Layer is activated, or when you change PGM CHG, as described before.

It’s simple what I want to achieve, that vstlive changes the sound to my keyboards and that I also use some vst. I just created an empty song, I connected the modx to the midi port and if I play a vst it plays regularly. Now, let’s say I also want to match the piano sound of the MODX (therefore not a vst) so I create a new Layer, DO NOT place any instrument otherwise that vst will play and I don’t want to, I put the MSB and LSB codes plus the correct program change and I would like worked. With different configuration and PC on another platform with the same codes it works, so I suppose that either I’m doing something wrong in vst live or the program isn’t working as it should.

You know that you can select MIDI Outputs there, not just plugins?
If you don’t assign anything to a Layer Instrument, the Layer will simply do nothing at all, no matter what you do.

If you use the ModX for both input and output, you should check its “Local” setting. It may get confused if it gets its own data.

Finally, you may well split the action if you want to. For that, you can create a 2nd Layer, set its INPUT to (nc), and the Instrument to Midi Outputs/ModX (or whatever name you assigned to the output connected to ModX). It should send PGM CHG and Bank Select seperately to the ModX then.

But if no Instrument is set, nothing will happen with such Layer.

PERFECT WORKS!!! I hadn’t realized that in the vst you had to choose the midi OUT port, I thought the input port was enough … anyway if I can say it is not very “user friendly” to mix the vst with the midi ports … honestly I would never have arrived at intuition! So everything was correct apart from that “bloody” door!!! TKS SO MUCH!!!

Glad that it works for you!