Help needed! Import problems.

Hi guys!

I’m importing a batch of 15 stems. Some are mono, some are stereo.
I want them all to be imported to stereo tracks.

Can’t figure this one out.

Add 15 stereo audio tracks and select the first track. Then import the files and when Cubase ask select import to separate tracks.

It worked!

Thanks a lot!

It still bothers me a bit though. Seems a bit clumsy to me.

Anyways, thanks!

Ja but it makes sense that when you import audio files that Cubase will create a mono track for a mono file.

Not really.

When importing a batch of mono and stereo audio you are presented with the option to split audio into the L&R channels. Even the mono ones.
Steinberg might as well add the option to import to stereo track and save us some extra steps.

And I guarantee that if you did it that way a whole bunch of people would query why you did it that way and say it didn’t make sense. I think it’s ok the way they’ve set it up personally but each to their own.

Best Regards, Dave