Help needed with midi routing please.

I have a Roland TD30 which is connected to Cubase via midi in and out on a fireface.

Midi thru is set off within Cubase to avoid midi loop from Roland TD30. The TD30 is set to midi in. This configuration allows the sending of program selection from Cubase inspector however, when selecting All Midi Inputs in Cubase inspector am unable to connect a USB midi keyboard to the TD30.

Alternatively if I select midi thru in Cubase and turn off midi in on TD30. By selecting All Midi Inputs in the inspector I can now produce sounds from both the TD pads and the keyboard but cannot send program selection commands.

I have been using this setup for years. Only thing different I think is USB midi in for the keyboard which is incidentally an MAudio dumb keyboard so no midi control here.

Any bright ideas ?


Keep MIDI Thru enabled in Cubase. On TD30 set Local Control Off.

Thanks. Bad case of couldn’t see the wood for the trees.

Sorry I am back with this one again. When I have powered down both computer and Roland TD30 then restart both, Cubase no longer sends program selection messages. If I go to my Roland TD30 and switch midi in, on then off again all is well. Something seems to be causing a loss of communication. Any ideas ?


Do you send any SysEx to Roland at the beginning of the song by any chance?

No its filtered in Cubase. I think that was the default situation anyway.