Help please! endpoint configurations changing "randomly"

without making changes other than adding descriptive pages to my large orchestra score, the endpoint configurations for percussion are changing. (see both configurations below . it makes no diff if i change to halon) . a symptom is that a large gong now sounds like a flute.
i spoke with steinberg support and they suggested i contact noteperformer.

Can you say more about the way in which the playback configuration is changing? What happens if you re-apply the NotePerformer playback template?


Please excuse this email to both of you. I thought it best to give you both what I know as it is not at all clear to me if the issue lies in NP or Dorico are as the result of a handoff between them.

I am including two versions of the project which show the symptom. I do not play around with the playbacks other than to specify that I want noteperformer with eastwest. However that specification took place before version 80. As an long term software developer I have the habit of saving a new version for even minor changes so the difference between these two is likely to be as small as just putting in a slur before I took a break.

If you look at mvt 2, mm28 at the large gong, you will see that it is correct in version 80 but in version 81 it is clearly not a gong.

I have created this issue previously by just adding a new instrument and tried that in this case but failed, so the root cause is currently a mystery. I will say that as I have made changes, sometimes just adding pages, the specific instruments with the issue , always percussion, have changed. I did notice that the ew percussion group tends to disappear. I would put it back as a test but am not sure how to force it.

This is for the clash cymbol in version 80

And this is version 81

Here is the side by side of the channel setup… note that they have changed but not by me (right side is v81)

Should either of you wish to set up a face to face and play around on my computer, we can arrange that.

Case # 03003867 has been opened with phone support(Steinberg). Also, should it be useful, if there is a logging mechanism that we can turn on, I will be happy to do it. I can be reached via email or at 617-605-0484 (US Eastern Time).



Fyi… I am running dorico,. audio engin the file version for the NP playbackengine is

I am running windows 11

My computer as 3tb of ssd with this configuration:


OS Name: Microsoft Windows 11 Pro

OS Version: 10.0.22621 N/A Build 22621

OS Manufacturer: Microsoft Corporation

OS Configuration: Standalone Workstation

OS Build Type: Multiprocessor Free

Original Install Date: 3/2/2023, 16:08:46

System Boot Time: 9/26/2023, 11:53:04

System Manufacturer: Dell Inc.

System Model: G5 5505

System Type: x64-based PC

Processor(s): 1 Processor(s) Installed.

01: AMD64 Family 23 Model 96 Stepping 1 AuthenticAMD ~3300 Mhz

BIOS Version: Dell Inc. 1.15.0, 3/14/2023

Windows Directory: C:\WINDOWS

System Directory: C:\WINDOWS\system32

Boot Device: \Device\HarddiskVolume1

System Locale: en-us;English (United States)

Input Locale: en-us;English (United States)

Time Zone: (UTC-05:00) Eastern Time (US & Canada)

Total Physical Memory: 32,122 MB

Available Physical Memory: 14,755 MB

Virtual Memory: Max Size: 36,986 MB

Virtual Memory: Available: 12,493 MB

Virtual Memory: In Use: 24,493 MB

Page File Location(s): C:\pagefile.sys


Logon Server: \DESKTOP-1UMCMCD

Hotfix(s): 4 Hotfix(s) Installed.

Network Card(s): 5 NIC(s) Installed.

01: VirtualBox Host-Only Ethernet Adapter

Connection Name: Ethernet 3

DHCP Enabled: Yes

DHCP Server:

IP address(es)

02: Realtek PCIe GbE Family Controller

Connection Name: Ethernet 4

DHCP Enabled: Yes

DHCP Server:

IP address(es)

03: Killer(R) Wi-Fi 6 AX1650x 160MHz Wireless Network Adapter (200NGW)

Connection Name: Wi-Fi

Status: Media disconnected

04: Realtek USB GbE Family Controller

Connection Name: Ethernet 2

Status: Media disconnected

[05]: Bluetooth Device (Personal Area Network)

Connection Name: Bluetooth Network Connection

Status: Media disconnected

Hyper-V Requirements: A hypervisor has been detected. Features required for Hyper-V will not be displayed.

----daneil’s email:


September 27

Can you say more about the way in which the playback configuration is changing? What happens if you re-apply the NotePerformer playback template?

ramblings_orchestra_v2_80.dorico (2.69 MB)

ramblings_orchestra_v2_81.dorico (2.32 MB)

This is definitely something of a mystery. I wonder whether Arne @Wallander might have any ideas what’s going on. I cut down your project, Bernie, to just the percussion kit, and reapplied the playback template, and it only loaded the Drum set (sticks) patch rather than the Orchestral percussion kit, which is why the sounds aren’t ideal. I created a new project using the same instruments, and that works OK: it loads the Orchestral percussion kit as expected.

does-not-work.dorico (524.8 KB)

works.dorico (524.8 KB)

There is a clue lurking here somewhere deep. When I opened the projects you just sent, they both had the orchestral percussion kit. I did notice that the projects had to be downgraded from which ever development version you are running.

Is there another file such as a configuration file on my machine that may be affecting this? I realize that is a bit of a “hail mary” but… just a thought.

There are a lot of log and xml files. Would any of these help?

I wonder if this might have something to do with (or the same cause as) my thread Duplicated percussion kit loses NotePerformer links

There also after reapplying the NP playback template, percussions switched to different sounds without any obvious reason for it.

That’s strange. I did “Edit Percussion Kit… > Export Kit”, and the XML file has a hidden Drum Kit instrument. Could that be why it resolves to the drum set MIDI program?

1 Like

No, I don’t think so. When you create an empty percussion kit, Dorico gives it the standard drum kit ID, but that shouldn’t unduly influence what it does when it tries to determine what sounds to load, as it’s looking primarily at the instruments in the kit. In our development builds we have changed this in any case, so that when you create a new empty percussion kit and assign it to a player, it starts with a user ID rather than the factory ID for a drum set, but that change won’t appear until the next public release.

I tried changing our “presets_for_instruments.xml” file so that the “instrument.kit.drum.set” instrument points to Orchestral Percussion. It resolves the problem. It’s this line.

We can’t change it permanently without losing the drum kit, but maybe it provides a clue? For some reason, that instrument ID is involved in making Dorico assign MIDI Program 100 (drum set) instead of MIDI Program 15 (percussion).

1 Like

I have found on several occasions that individual drum or cymbal sounds have suddenly started sounding flute-like. Not sure what causes it. I Save As… under a different name often for backup purposes to change the time stamp part of the file name, but I cannot say that causes it.

It would appear that it is not just me. We appear to have something in common here. I think it needs some further investigation

I’ve spent a bit of time looking into this today. We can reduce the likelihood that Dorico will load the drum set sound for a kit that has the standard drum set instrument ID but none of its instruments. However, I’m not sure under what circumstances you can end up with a pitched instrument being loaded instead of an unpitched instrument. If you have any reproducible steps that would allow us to catch that happening in the act, please let us know.


Thanks. I have been working on that. I realize how important a reproducible test is. I worked on a compiler years ago and we had a bug that we could not fix for 2 years till a customer send us a dirt simple way of creating the issue… then it took about 15 min to fix.

I will keep testing.


1 Like

This broke it for me.

  1. go to mvt II MM 63 and play the clash cymbol it should sound like a cymbol

  2. add solo viola

  3. select play view

  4. select newly added solo vila… should say "halion sonic’

  5. play menu - playback template - switch to note performer

  6. go to mvt II MM 63 and play the clash cymbol for me it sounds like a flute

ramblings_orchestra_v2_75.dorico (2.57 MB)

I can reproduce this. When I followed your steps, the percussion sounds are assigned to flute. Not just in NotePerformer, but it says “Flute 1” in the endpoint.

Meanwhile, the strings are assigned percussion maps and play percussion sounds.

1 Like

The good news is that following the changes I made yesterday to the handling of percussion kits that use the default drum set ID but don’t contain any of the appropriate instruments, those particular steps no longer reproduce the problem, so hopefully the issue will be resolved in the next update.