Help please with audio warp-keep before stretch after optio

I want to audio warp a bass line to tighten up the track but I am unable to see where the option to “keep before _ stretch after” the little metrognome marker. Somehow I am not getting this option but every stretch is expanding all markers both before and after the position am dragging. Please put me out of my misery and tell me what I have done to lose this option.
I have had it in the past!

I solved it. some how never heard of the algorithm choice. I changed from mixed to plucked and it works.

http://www.kompoz.com/music/player/511623/516241/2
better link if the other one does not work.