Help request: MIDI input filtered by chord pads

Hi there,

I’m using a keyboard to input MIDI to a VSTi in Cubase 13, and it seems that I can only actually play the chord pads - nothing else. It also seems that the routing is correct, with the MIDI input for that VSTi being set to “USB-MIDI”. In the lower right-hand corner of the Cubase window, there’s a meter showing MIDI input, and signals from all the keys of the keyboard are being received in the DAW (the meter lights up no matter what key I press). So I’m guessing it’s an internal routing or filtering issue.

I hope someone can help me get this right! Thanks!

I’m sure we can get you sorted out. Can you post a screenshot of the Inspector for the Track showing its MIDI routing.

Sorry for the delay @raino, here is a screenshot, hope it’s what you meant:


I initially read your post as saying that you could only use the Chord Pads to trigger the VSTi. But on rereading it sounds more like the only thing that your Keyboard Controller can trigger are the Chord Pads. Can you clarify?

Are you sure that the port “USB-MIDI” actually corresponds with your Keyboard Controller and not something else? What keyboard are you using?

Can you post a screenshot of your MIDI Port Setup in Studio Setup, make sure to expand the Window so all the Inputs can be seen.

1 Like

Yeah, I guess that’s right – the keyboard only triggers the pads. There’s only one MIDI input (and it’s the only USB connection to the computer), and it’s from a Kawai electric upright – not a proper MIDI controller, but in the past this did work. The signal is getting to Cubase fine, and the signal meter in the bottom right-hand corner of Cubase is lighting up:
Screen Shot 2023-11-18 at 5.20.23 PM

Here’s the MIDI Port Setup screenshot – very basic as you can see:

That all looks normal. But I see now that in your Inspector screenshot the top “Basics” section is collapsed. You can expand it by clicking and I’m guessing when you do you’ll find that you don’t have Monitor enabled so the Track isn’t receiving any incoming MIDI Data.


Hmm… it is enabled…

I’ve attached a test .cpr file, and as you’ll see it is receiving data – I can successfully input via chord pads to the instrument. Any other key, nothing goes through.

Test.cpr (152.7 KB)

Try right+clicking near the bottom of the Inspector and set the MIDI Inserts to be visible. Then load up the MIDI Monitor and look at what it finds when you play.

Just noticed you are on a Mac, I wonder if there might be any issues there. @Martin.Jirsak would know if there is (and likely spot the obvious thing I’m not seeing).

I’m not seeing MIDI Inserts as a section option…
And I can’t find the MIDI Monitor…
I’m also guessing it’s the Mac that is the issue.


No, there is a known issue like this on Mac.

What happens, of you close the Cord Pads Lower Zone tan? Can you also grease just the Cord Pads?

Clicking on the chord pads works. When I close the chord pads or use a different tab (mix console for example), I can’t input anything (not even assigned pads from the keyboard).

Well you have to be able to see the Inserts before the Monitor becomes available.

It should look like this

What are you seeing instead?

Also it’s not totally clear from your images if this is a MIDI or Instrument Track.

If you launch the On-Screen Keyboard (Studio>On-Screen Keyboard…) can you use that to play the track?

Huh! “MIDI Inserts” was literally not a selectable option. Will for just to make sure tomorrow, but I honestly did not have that long a menu!

It’s an instrument track.

The On-Screen Keyboard did not work.

Wait – is that a MIDI or instrument track that might have “MIDI inserts” as an option?

They both have MIDI Inserts.

Which edition (Pro, Artist, etc.) are you using?

Also when posting screenshots it is helpful to zoom out a bit and show some context around what you want to display. For example I’m still not sure what the Track Types are for each close-up you posted. Look at what I’m including in the screenshots and aim for something similar. We’ve eliminated some of the most common causes for your problem, so now we’re kind of looking for a needle in a haystack & in that situation its good to see a bit more of the haystack.

1 Like

It’s Cubase LE AI Elements 13 on a MacBook Pro (Silicon chip).

They’re all instrument tracks; will keep the screenshots zoomed out in the future!

Turns out you don’t get MIDI Inserts until Artist, which is going to make it harder to sort out what’s going on.

Have you tried using the on-screen keyboard to see what happens?

The on-screen keyboard doesn’t work at all; it doesn’t trigger the chord pads either (even if I change the octave range on the on-screen keyboard).