Help Troubleshooting Choppy GUI Playback


I’m rebuilding a new template in Cubase Pro 10.0.10. Starting with an empty session I began adding midi tracks and noticed that the more midi tracks I added the playback became more and more ‘choppy.’ Almost as if it’s stalling or freezing for a split second. Monitoring playback with the Time Display open I can see the ‘choppy’ movement of the numbers. On my system the problem gets very noticeable around 1,500 midi tracks.

Here’s what I’ve tried so far, with no improvement:

  • Removed all ‘midi in’ & ‘midi out’ connections on the midi tracks, no data, just empty tracks.
  • Un-checked all midi chase preferences.
  • Tried moving all the midi tracks into a closed folder.
  • Changed the audio buffer settings.

If this is hardware related, it may be that I’m using an older AMD Radeon HD 5700 video card. Would a new video card improve this? If so, which cards are recommended?

Any help or assistance will be greatly appreciated!

My system specs are:
Cubase Pro 10.0.10. Windows 10 pro. RME Madi. Dual Xeon X5675 3.07. 64gb ram.

Hi, did you find a solution? Anything above 1500 MIDI tracks becomes very choppy, exactly as you described.

I’m using a GTX 1080 with maximum power for Cubase set in the Nvidia Control Panel, so you can rule out the GPU.

I also tried disabling MIDI chase, to no avail.

Anyone else working with high MIDI track counts? Curiously, this does not happen with audio tracks.


I appreciate the reply!
No solution yet. I was beginning to think it was just my setup having the issue. I guess not many users working with such high MIDI counts. Still trying to track down the cause and possible workarounds. I will post any progress or improvements I find, and please do the same if you run across a solution.


The lag has been there for years. Things have gotten better over time, but it is still there. The more tracks you have, the laggier it gets.
Very annoying to have to keep updating in the hope they finally fixed it


I reckon you guys are also working with orchestral samples? In order to manage high MIDI track counts, it’s mandatory to keep them disabled. Bonus points for using folders, as having thousands of tracks visible will bring any system to its knees.

Even though MIDI tracks in Cubase are much more efficient than any other DAW I’ve tested, they still do some processing that adds up with such high numbers. So the trick is to keep your libraries safe within folders and enable tracks as you go with a key command.

I went a bit over the top to see how far I could push this method and had 30000 (thirty thousand haha it took 1h8m to load, in case you are curious) disabled MIDI tracks playing back flawlessly. Cubase didn’t even flinch, it was pretty impressive.

Realistically speaking, my template is around 4000 tracks (single articulations) across dozens of folders and, paired with the search/visibility functions, I’m only a click away of auditioning any samples I need. I’m never going to actually be using all 4000 tracks. I just need instant access to them hence why my template is that many tracks and not 100 tracks.

The only issue is that Cubase resets the audio output linked to that particular track (see image below). It does not mess with the audio routing per se but you will have to pick the output manually if you want quick access to the mixer from a MIDI track.

Everything else is kept: midi input, output, midi inserts, sends, modifiers, expression maps; all the sensitive information.

Hope that helps somehow!


Specs: Cubase 9.5.41, VEPro 6.0.17226, Windows 10 Pro 1809, MOTU UltraLite AVB.

Thanks Cesar, I had no idea you could disable MIDI tracks. My largest projects are about150 tracks so there’s really no point in keeping the entire template online eating CPU. As you said, I’m just looking for a way to instantly access my samples. That’s the perfect solution.

Despite the many bugs (why track presets are so broken???) I’m not aware of any other DAW that could pull this one off. I now have 3,500 tracks ready to go and it’s buttery smooth to play. Impressive indeed.

Thanks again.