help with a repeat bracket mid-bar

I am struggling to reproduce this in Dorico.
The bracket has to start mid-bar.
Is there a workaround to get the desired result?
Thank you very much!

bracket mid-bar.png

Do you use a dashed barline anywhere in the piece? If not, set dash length to 0 and add a dashed barline there.

Or three 6/8 bars with hidden time signatures and a bar count change. Or you could repeat the first half of the bar for the second ending.

P.S. Not really a ‘correct’ realisation under the 1st ending. I wouldn’t play an e-natural over the b-flat in the LH as it doesn’t belong to the chord. Just sayin’. :wink:

oh sorry, the piece is in G-Major. So it is e-natural over b… which is fine :slight_smile:

Yes, this is what I did. But we need to be more flexible in Dorico when it comes to repeat structures, example below:

waved repeat bracket.jpg

Thank you Dan, I was hoping for a solution with an easier workaround :wink:

Sorry about the assumption that it was in d minor. Still, since it has a 6, the chord on the b-natural should be a first inversion G-major chord.

Seems pretty easy to me! Add an invisible barline, then add a repeat ending there.

BTW, entering the music in 3 6/8 bars with hidden barlines and time signatures (and excluding two of the bars from numbering) is a very easy way of doing this.

Having the possibility to create invisible barlines without having to hijack the dotted barline would seem to be a handy feature.

I’ve had to do this, too, and one of the ways I did it was to wait until the layout was finished and then move the ending in Engrave Mode. It’s a bit of a kludge but it works.

yes, spontaneously I tried the invisible barline route first.
Somehow I did not get it to work:

  1. Select the note (in front of which I want the barline to appear),
    Type Shift-B, then in the popover
    Type “invisible”
    Finish with Enter.
    … nothing happened …
  2. 2nd thing I tried:
    Go to and select the note (in front of which I want the barline to appear),
    Hit Enter
    In the right panel click the 1. bracket
    Hit Enter and the Space bar (like when entering hairpins in certain positions)
    … nothing happened …
  3. started this thread
    … which is not intuitive, but very helpful :slight_smile:

There are no true invisible barlines in Dorico at present. That’s why you first need to go to Engraving Options–Barlines and set “Dash length for dashed barlines” to 0. Then to insert the “invisible” barline, Shift-B, colon, Enter.

If I am not mistaken, I do remember putting “invisible” into a popover for something in Dorico - and it was actually working… It must have been something else than barlines though …
:point_right:t2: … it was Shift-C and then “invisible” Enter - for an invisible clef!
So may be this would be a suggestion to be extended to the Barline Popover …
unless there is some fundamental reason against invisible barlines …

Just out of curiosity, does Dorico still allot horizontal space to a dashed-turned-invisible barline?

Yes, but easily overcome in manual note spacing.


I’m looking or a way to make a bar line invisible, but I do not know where to set the dash length to zero. I have tried looking in Engrave Properties and Write Properties to no avail (unless I missed it there).

I also tried to find the character/shape for the tick bar line (instead of the dashed bar line) to replace it in the Symbol Editor, but did not find anything suggestive of that tick-mark there.

trying to change the color of the tick mark did not work either. :confused:

Derrek, the gap length and distance are global. Check Engraving Options > Barlines.

Thank you. Success.