Help with Halion Sonic // locking Cubase 6.0.7 - Solved

Just exploring Cubase 6 more and want to mess with Halion Sonic.
I’m running Cubase 6.0.7 64 bit on Win7 with 12 GB RAM.
I can add an instrument track ok and I can hear the base sound triggering with a midi controller, but if I try to change the patch or open the instrument, Cubase locks. I can actually still play the original patch on my midi controller, but Cubase just shows the hour glass pointer…it’s trying to do something, but can’t seem to get over the hump.
All the other synths load up fine.
I thought it might be having a conflict with another VST, so I deleted all my defined paths, but it didn’t help.
Any ideas or suggestions in getting it to work properly?

Problem solved.
Ironically it was a USB License key issue.
I moved it from the USB3.0 slot to a USB2.0 slot on my PC and it solved the issue.
Not sure if it was the USB3.0 vs 2.0 or just the different slot that solved the issue.
I would like to give kudos to Steinberg support.
I opened a ticket and they acutally called me, set up an appt and remoted into my computer.
They even had US based support (for us living in the US).
They guy I worked with was helpful and, while he didn’t have the answer, he did suspect a license key issue and asked me to try a few simple things. Those things didn’t solve the issue, so, based on his suspicion, I moved the License key and that solved it.