help with small matter that is driving me crazy please

You guys are going back and forth between 2 things.
1)Getting to the associated channel to control plugins from a MIDI track
2)Getting to the instrument associated with an instrument or MIDI track

The ‘e’ will always bring up the channel editor, unless you alt+click. The inspector has a direct button to VSTi on both MIDI and instrument tracks (several actually). There are also several key commands you can map to gain various kinds of focus on instruments, plugins etc…

Yes but if the click the e button for the instrument in the inspector when your playing midi for that channel, it automatically comes off the midi channel you were playing & goes to the instrument channel. The only way to get around it it holding alt & click e in the inspector & that opens another window for the audio mixer settings & you can still play the midi!
What I really want to be able to do is simple. When in prefs you have ticked “sync Selection in project window and Mixconsole” & you are flying up and down your audio & instrument tracks midi tracks etc(including multitimbral) in the project window, & your edit channel window is open, I just want it to not show the midi channel AT ALL but just the Instrument Channel (the one the same as the Audio channels) thwe one with the eq on etc.
It seems the only way to do this is choosing a TRACK instrument instead of a RACK Instrument, but then it still does not work for multitimbral,… OR pushing the “e” button in the inspector with the Alt key held.

Anyway, I hope Steinberg can put this feature in.

P.s. I cant seem to get my Audio output to show up next to my midi output as in the pictures above, even if Ipush the arrows etc?? Any ideas anyone please?? :slight_smile:

It sounds like you have the preference ‘arm selected track’ on, or something like that, which un-arms the track when the other track gets selected. If you turn that off and manually arm midi tracks you’d like to play live (or press the Monitor button I think too) then you will still be able to play while editing the audio channel. Does that help at all?


Where is “arm selected track” or whatever it’s called please?

Aha, I found it in Preferences->Editing->Project&MixConsole->Enable Record on Selected MIDI Track. Also one for the audio tracks. I have them both switched off, and I use the R key to arm a track or click the ‘Record Enable’ button (to give it it’s correct name!).


hi Mike,
I just tried it & it still brings up the midi channel like I explained earlier. Thanks for trying to help though :slight_smile:

Well, I’m confused now because surely we’ve addressed all your problems haven’t we? a) Click the other ‘e’ button on the inspector to see the VSTI’s audio channel, and now b) with the preference off you can still play/record the record enabled midi track(s). Other than that, there’s no way of scooting past the midi channel settings.

Anyway, how about you move the channels side-by-side? E.g. use the project window to put the VSTi audio channel below the MIDI channel which plays it. Also the VSTi itself has a channel which may contain automation, and I put that below the audio channel too. Then they’re all together right next to each other.


Hi Mike,

No it can’t do what I want it to but have found the nearest best thing, thanks for your help.

Hopefully Steinberg will put this feature in soon. Cheers, Codsworth :slight_smile: