Help with the playing technique editor [Solved]

Dear fellow Doricians,

I watched yesterdays live stream with John Barron and tried today to modify my own playing technique. I duplicated the ° (harmonic playing technique) to create a text based “armónico” playing technique — I’m working on a spanish score.
I cannot get this one to work, even to show anything : in the playing technique panel, it’s blank, and when I apply it, there’s nothing — just like in the big window (graphical editor ?) but I swear I choose text, and I choose playing technique text (as font). Could you tell me what is wrong here ? And why can’t I delete my playing technique once I see everything is not as I want it to be?
Another thing : I cannot write armónico, I have to get rid of the accent. This is a mistake in Spanish. Thank you to note that we also need to be able to input accents in there…
Of course, I managed to get my playing technique duplicating and editing a text based playing technique, but I do not understand the logic behind not being able to achieve that result using a glyph based playing technique.
[Edit] About the accents in spanish, I noticed that I cannot input them in the suffix text of Dynamics, which is also a problem here for me. I probably will have to give up on the spanish touch and write everything in italian — it feels like acculturation…

I get the same behaviour: duplicating the harmonic (o) technique, making it a text based technique and inputting the text doesn’t work, the text doesn’t show up.

I can input accented characters both in the dialog and in the properties panel. I suspect there’s something going wrong on your end…?

I don’t know what happened… I ended with a non responsive Dorico 2 when trying to go back to English for the interface, had to force quit, and everything works now as expected. I’ll modify the title. Thanks Florian for stepping in :wink:

Now I’m working again and I notice that in Write mode, I’m not able to input the accents (súbito) in the suffix of dynamics (properties panel), while I can do it in Engrave mode.This is strange. In write mode, when I input the accent, the field is “blanked”.

I’m able to type “súbito” into the Suffix field in the Properties panel by typing Alt+E followed by u as normal.

Dear Daniel, with a french keyboard, the acute accent is available by pressing alt-shift-1. Maybe this conjunction of keystrokes is used for something specific in Dorico’s Write mode ? [Edit] If I enter p súbito in the dynamics popover, it does work properly…

Unfortunately we don’t have complete control over the keyboard handling for edit controls like the ‘Prefix’ and ‘Suffix’ controls in the Properties panel. If it’s an option for you to use the alternative “dead key” combinations to produce accented characters on a French keyboard, I hope that would work, even though I understand that’s less than ideal if you are very accustomed to being able to obtain the accents another way.

Dear Daniel,
I have found that the Prefix/Suffix fields in Engrave mode do not exhibit the strange behavior they have in Write mode. Now that I have a workaround, I’m satisfied but I think it is worth sharing it here.

I guess the issue is that Alt+Shift+1 is being interpreted as a key command for the view type rather than as an input for the text input control, and since those commands aren’t active in Engrave mode, they make it through to the text input instead.

Yes, but my key command for view (page view) is command-alt-&, not shift-alt-& (in my french keyboard, you need to do shift-& to get 1). If I open the preferences > Key commands editor, and add aalt-shift-& for page view, the program does not tell me anything, which means it is not used by it for something else — at least nothing that the command editor can handle. But it does not accept either, certainly because it is a dead key.

Does anyone have an answer to Marc’s question about deleting a playing technique? I have one I created that I’d like to delete, but I can’t figure out how to get the Delete button in the Playing Technique Editor to become enabled.

Is the playing technique in question still in use in the score? If so, try deleting it from the score altogether.

It was used in the score, but didn’t have the desired effect. I removed it from the score, but I am unable to delete it from the list of Playing Techniques.

If you could zip up and attach the project here, together with details of which playing technique you can’t delete, I’ll be glad to take a look.

Well, I just tried it again and I was able to delete it this time. I think what happened before was I clicked the edit (pencil) button without first selecting a playing technique from the panel, and when I selected my playing technique from the list in the editor, the Delete button remained disabled. This time round I selected the technique from the panel first and then clicked the edit button, and the Playing Technique Editor opened with my technique selected and the Delete button enabled.