Help - Xtouch is triggering soft synth sounds

Hi

I posted in an old thread here but thought I might get help faster

I bought an xtouch and set it up with cubase pro 9 via USB - MCU set to Cubase in Cubase

However, the x touch when trying to mix triggers sounds in omnisphere no matter what i touch on it. I have been in midi devices setup and cannot find where to fix this

can someone tell me how to stop the xtouch from triggering soft synth sounds and just be used as a mixing tool?

Thanks

This is normal. Cubase sees X-touch as just another MIDI device just like keyboards. In order to stop this you must:

  1. Not to use ‘All MIDI inputs’ as input for your MIDI/Instrument track
    or
  2. Remove X-touch from ‘In All MIDI’ in Device Setup -> MIDI Port Setup
    or
  3. Both 1&2 (recommended)

ah thank you, i went into the device setup, and unchecked the all midi in square and now it works!

thanks so much!