Please help me

You can switch to Engrave mode, turn on note spacing, select the handles on the barlines, and use Ctrl-Alt-left arrow to reduce the width of those bars. You may also want to use “Make into system” to bring some of the bars from the second system into the first system.

Hi Dan
I need to set as DEFAULT bar tight spacing!!!

Check Engraving Options–Rests–Multibar Rest Spacing. You can set minimum and maximum spacing values for empty bars, both singles (short) and multiples (long).

Hi Dan,
Multibar rest spacing its O.K.
I need single bar tight spacing

Set “Width for single multi-bar rest” and “Minimum width for a multi-bar rest” both to 0. That should give you pretty tight bars. That’s as compact as you can go without manual adjustments.

Single bars of rest are still “multi-bar rests” as far as Engraving Options are concerned, assuming you have empty bars set to display bar rests (Layout Options–Players–Bar Rests, “Consolidate [Multi-bar Rests]”).

tight bars.png

Still LONG!!!


Something else is wrong with that layout. That doesn’t look right; the empty bars should not be that long. Have you removed all manual note spacing?

If that doesn’t resolve the issue, would you be willing to post the project here for us to look at?

Thats it
Untitled Project (548 KB)

Hi Dan I need this part make one page only!!!

Hi, it’s not that difficult to get this all on one page.
You can either reduce the “inter system gap” in Layout options/vertical spacing/ to let’s say 6 and it all fits on one page.
Or you can change the “Space size” in Layout options/Page setup/ to 1.56
Or remove the flow header which you might not need or modify the system margins.

Or if you really want to mess with the empty bars, which i personally find OK the way they look:
Go to Engrave mode, firstly remove all manual system breaks, slightly overfill the systems until you have the 3 systems integrated on one page, go to the “note spacing tab” on the left,mark any of the empty bars right barline boxes and press STRG+ALT+LeftArrow to modify it’s width.

Good luck

From what I can tell, a single bar multi-rest is subject to exactly the same rules as an H-Bar rest, regardless of what you’ve set for “Width for a single bar multi-rest”. It doesn’t matter whether you’ve set Engraving Options to show an H-bar or not - these rules still apply:

This means that a single bar multirest can’t actually be any shorter than the combination of

  1. The width of the H-Bar itself (whether shown or not).
  2. Twice the gap I’ve highlighted in green - setting number 5.

Changing setting number 5 will be a compromise, because it will affect the width of actual H-bars as well as single bar rests.

Some other thoughts…

Rehearsal Marks are causing many of the issues. Some suggestions…
Reduce padding and spacing for the rehearsal marks.
By default the Segno and Rehearsal Mark are stacked vertically. Move one of them to the right and position closer to the staff.
Several Rehearsal Marks are right after a trill. In the properties panel disable the trill line so it doesn’t conflict with the Rehearsal Mark.

For the multi-bar rests, there is another setting minimum width for a multi-bar rest which can be reduced.
Notespacing can be reduced in Layout Options to get tighter spacing.

After all this, you may still need to manually adjust in Engrave mode.
Untitled Project (549 KB)

Hi jirka1, I looked at your project and I think I can give you a few suggestions (I assume you use Dorico 2.2). The attachment has most of these.

  • In Layout Options > Page Setup, the staff size (Rastral) is 3 (7mm). If you change this to 4 (6.5mm), the music is slightly smaller but still fairly well readable. Of course, it depends who is going to read it and at which distance.
  • Insert a Frame Break at the beginning: in Engrave mode, click the first item (the 2/4) and type shift-F. Select the purple signpost for the Frame Break, and, in the properties panel at the bottom, switch ‘Wait for next frame break’ on. This will force all music on 1 page (even if it’s too tight).
  • Maybe use smaller rehearsal marks, or at least don’t use the boxes around them. To make them stand out more, you might use a different font (I used Arial Black in the attachment). Also decrease the minimum vertical distance between staff and rehearsal marks.
  • Try to set the minimum width for a multi-bar rest to 0 instead of 1. It makes a difference. But I think width 1 is fine.
  • Omit trill lines, they force rehearsal marks C and D up.
  • In Engrave Mode, drag the Segno next to the rehearsal mark E.
  • In bar 20 and 52, force stem down on the four notes in the beamed group. It’s more compact.
  • Decrease the minimum distance between the staff and dynamics.
  • You could omit the 2/4 indication in bar 21 (letter C)
  • The layout has both a main header with the Project Title, text frames with room for composer and lyricist, and a Flow Heading with the flow title. If this project has 1 flow only, you might omit the flow heading (Layout Options > Page Setup > Flows).
    Hope this helps.
    Untitled Project 1 (549 KB)
    [edit: some of this duplicates other replies already - this forum is fast :smiley: ]

thank you for everything!!!