Hiccup in microtonal playback

Dorico (4.3) can’t handle the playback of the microtonal phrase in the enclosed example file. Even though there’s a slur, and the Key Editor shows that the notes are of correct length, there is a hiccup on the second note (E-arrow-down) - it’s stopped short so it’s staccato, not legato. The second bar shows a copy of the same phrase but with the offending note transposed. Now there’s legato, as notated. Perhaps this is a problem in NotePerformer (4) and its implementation of the VST3 tuning parameter? I’m guessing it’s doubling a single midi note and that kills the sound.
hicupp.dorico.zip (769.5 KB)

What if you set the playback end offset of the note before the E-arrow-down in your example to -1? Does that end the hiccup?

Yes it does - thank you! And now when I look at the notes in the Key Editor with an extremely large zoom setting, I can see that they do in fact overlap slightly. I wonder where this overlapping comes from. For a monophonic instrument part it can’t be there by default, even with a legato slur, can it?

Legato notes are played back 105% of notated duration by default - see playback options>timing>note durations.

Normally, when two adjacent notes under the same slur have the same pitch, Dorico shortens the first note so that it ends just before the second one begins. Presumably because of your custom tonality system, Dorico does not recognize that E-natural and E-arrow-down have the same MIDI pitch number, and because the note before the E-arrow-down is not shortened, the E-arrow-down ends when the previous note ends, causing the E-arrow-down to sound staccato.

1 Like

Yes, exactly. The first note sends a Note Off message while the second one is playing. Changing the length. of legato notes to less than 105% (as I learned from Janus above) takes care of the problem.

I thought the Playback setting for Legato note durations would work but it doesn’t. In fact, it has no effect at all, for any legato phrases. Is there some other setting that overrides it?

NotePerformer does not use the Note Durations in Playback Options>Timing. Instead, its expression map has Playback Options Overrides which specify the note durations. However, if you change the duration of legato notes in this expression map, NotePerformer may not recognize the notes which should be legato and therefore may not play back legato phrases correctly.