Hidden feature: Disabling instruments tracks

Steinberg have quietly add a new useful feature.

We can now disable instruments tracks. (In previous version it was exclusive to audio tracks.)
The entire channel is disabled not jut the VST Instrument.

Thats a great news for people who build huge templates (orchestral, soundtrack)
I use to freeze unused instruments for that.

There one small bug. When enabling a instrument track, the midi input SOMETIMES switch to ‘‘not connected’’ and I have to reselect ‘‘All midi in’’. I wish they will fix that shortly.

This is a great update!

Whoa! Awesome!

Oh snap. I will have to try this out. I’ve been asking for the ability to Freeze instrument tracks with no MIDI data on them, but this might be a reasonable alternative?

That is in C7.5.3.

Just tried it out with C8.0.0 and it works - even selecting multiple instrument tracks at once lets you enable or disable all in one go. Even assigned a hotkey!

But yes - when you re-enable a track the MIDI Input resets to “Not Connected” which is hugely annoying. It needs to remember the track’s previous MIDI input (ie: All Inputs)

Where in C7.5.3?

This is a seriously awesome addition for those of us with huge templates. However when re-enabling the instrument track, the MIDI input does come up as “not connected”.

Is this a bug we can get squashed? it takes a lot of the fun out of a very cool new feature.

I just came across this awesome feature and built a HUGE template using it but then also came across the “not connected” midi bug. PLEASE PLEASE PLEASE can you at least make it default to all midi inputs. I would be so grateful…

It’s not a actual fix, but since all of the tracks being Enabled should remain selected, a quick Shift+ALT while selecting All MIDI Inputs on a single track should do the trick. Yes the bug should be fixed, but in the meantime, it really shouldn’t take more than 3 seconds to remedy.

I’ve noticed the exact same behavior with Expression Maps recently.

As of Cubase 8.0.20:

(To recap, the MIDI input bug behaves like this):

  • Disable an instrument track, then re-enable it and the MIDI Input is still set to its last state (ie: “All MIDI Inputs”) (this is good).
  • However, disable an instrument track, save and close the project, re-open the project and re-enable that instrument track: it will revert to “Not Connected” as the MIDI input for the track. (this is bad)

In the exact same way, Expression Map assignments are lost after the project closes:

  • Disable an instrument track, then re-enable it and the Expression Map is still set to its last-assigned Map (this is good).
  • However, disable an instrument track, save and close the project, re-open the project and re-enable that instrument track: it will revert to “No Expression Map” as the Expression Map for the track. (this is bad)


    This is a royal pain. I love the ability to disable instrument tracks, but this needs to get resolved.



    I’m alllllllllso going to piggy-back here and add more:

I went digging for a way to create a macro for the visibility agents. I wanted a way to quickly hide or show all disabled tracks. (this would be great for workflow - I use templates that are resource heavy and often disable instrument tracks if I’m not using them, but they clutter up the session so one key-command to hide all disabled tracks would be beautiful.)

In Project Logical Editor, this is possible:
Container Type Is: Track
Property is set/not set: Is Hidden

However there is not a “Is Disabled” property for a Track. So technically it’s impossible to achieve this until Steinberg adds the property. Unless I’ve overlooked something?

It seems, they haven’t fixed anything regarding this issue yet? I find it costing unnecesary lots of time, too, to reassign the correct MIDI Input. It seems, Cubase just doesn’t save the MIDI Input of disabled tracks.

I also found my disabled tracks losing their connection to FX-channels. All FX-channels appeared twice as sends and didn’t get any audio input, after enabling the tracks. I had to restart Cubase to solve the problem. This happened only once so far.

Hello,

This issue remains in the collected issues, that is correct: http://www.steinberg.net/forums/viewtopic.php?f=231&t=71825

It should be solved on the next maintenance update.

Best regards,
GN

Yeaha ! Great news! :laughing: :laughing: :laughing:

please, tell us too that we don’t have to rebuild our templates all over again to get the function enabled ! :sunglasses:

tx,
kind regards,
R.

I notice in that thread the Expression Map issue I described above is also mentioned (easily reproducible). But I cannot find its own thread in Issues with it. Does someone need to create a thread? I hope it can be fixed at the same time as the All Inputs issue - which it should.

I tried to file a report for this and Steiny said they have the issue on record. (Missing quick controls, expression maps and midi inputs after re-enabling). Let’s keep our fingers crossed!

Hey guys,

I accidently found a temporary solution for this problem. When you open your project mark all of your instrument tracks - I usually do this with click on the first track and Shift+Click on the last. At an enabled track choose your desired MIDI-Input while holding Alt+Shift. This will set all your marked Instrument tracks to the same MIDI-Input.

It’s not ideal, but this only costs 15 seconds instead of wasting time whenever you enable new instrument tracks.

The 8.0.30 upadate hasn’t fixed this, I still have the broblem, very annoying and time consuming!!!

Hello,

Our QA and developers have reported the issue to be solved and have closed the issue, please start Cubase in Safe mode and try again.

Best regards,
GN

galanos wrote:
The 8.0.30 upadate hasn’t fixed this, I still have the broblem, very annoying and time consuming!!!



Our QA and developers have reported the issue to be solved and have closed the issue, please start Cubase in Safe mode and try again.

Best regards,
GN



I notice in that thread the Expression Map issue I described above is also mentioned (easily reproducible). But I cannot find its own thread in Issues with it. Does someone need to create a thread? I hope it can be fixed at the same time as the All Inputs issue - which it should.

just so there is no confusion there are two separate issues going on:

non recalling of expression maps for disabled tracks is here in issue reports and is waiting for a fix as it is still a serious issue in 8.03:

http://www.steinberg.net/forums/viewtopic.php?f=230&t=85428

I can also confirm I’m experiencing this issue.

Brand new project, hundreds of tracks set up to connect to the VEP instances, then disabled and saved as a template.

When I fire up a new project from the template, the instruments all read ‘Not Connected’ and I have to manually assign ‘All MIDI Inputs’. Only a quick job but still annoying.