Hidden Players deleted when closing a file with only one flow

I have an orchestral template. When I’ve finished working on a film cue (one flow per file) I hide all the players I’m not using as I don’t want to see them at the start of the score but I want the tacet part for the players for printing. However when I close the file and open it again the hidden players have gone leaving only the layouts for the tacet players. This could be a pain if I decide to go back to a cue and change the scoring, why does Dorico delete the players? See before and after pics!

I often have a dummy Layout called All Instruments which has all Players assigned to it. It is not meant for printing just a placeholder because I often have a Print score which may not contain every Player I have defined. As Dorico gets more features I am needing this less often but it may work for you.

Hi Craig, Thanks very much for your advice, much appreciated, that seems like a really good work around, works for me! Be great if players could just stay without the need to create the all instruments layout but as I’m using a template it’s not a hassle once set up. Thanks again. Ben

It’s interesting to me that we’ve had a number of posts about this issue recently, though Dorico has always behaved this way. Perhaps we really should reconsider whether completely unused players should be removed.


I think it would be really good if you could keep them. Perhaps as more people use Dorico for film scores this becomes more important. Of course we are really talking about a very specific usage where you need a single flow score without all the players but also with all the tacet parts and the option to bring players from the general ensemble back quickly. Craigs workaround is good meaning that I can go back to a cue and easily add back in a player I’ve now decided to use, but it just gives the players now and empty part i.e. no notes rather than a tacet part marked with tacet which is much clearer. The key for me here is the amount of material I have to deal with in a very small amount of time so anything that streamlines the process is a godsend, which doric is anyway but if it’s a quick fix in the program I’d be very happy to see it!

Just an update. I’ve found a workaround that keeps a real tacet part for the players that are not playing and doesn’t need an all instrument layout … Simply create a second empty flow in which all the players are selected to play and then hide that flow from all layouts. I think that seems to be the best solution for the moment.

1 Like