Hidden Staves Issue


I have been working on transcribing an Italian 17th century 5 voice cantata and I have a problem with the hidden staves functions. My issue most likely has to do with the fact that I imported XML data for this project, but the trick of deleting the clefs at the beginning of the piece doesn’t seem to do the trick. I am thinking that my issue also might have to do with the fact that there are multiple time signature changes which are hidden throughout that we created in order for us to have appropriate sized measures for this music.

Can someone take a look at this and help out? It is pretty urgent because I need to cut down the number of pages as well as just make a better layout. I can’t proceed unless I can get rid of these empty staves.

the project: https://drive.google.com/open?id=1jo1vD761sXesTcY7uQ4M5ohJ4c6B5z2S

Any help will be greatly appreciated,



There are a few issues here.

You have some key signature changes that are on individual staves, and in some places they are inconsistent between the staves, i.e. a singer who is resting in a section doesn’t have a key sig change at all. Change to Galley view, delete the key signatures from each staff and create a new “system” key signature.

In some places the lengths of the bars don’t match the hidden time signatures. Some of these bars have “explicit” rests (as if they were a pickup bar, though they are in the middle of the score) but in other places they seem to have been forced to contain a bar rest. In some cases the bar is longer than the given time signature, not shorter.

The voices in the import also look a bit odd. Some of the parts “randomly” switch between two voice, and near the end there are one or two isolated notes in a third voice (which is also used for the ossia bar). View / Note colour / Voice Colours will show that - but It might not matter, for the hidden staves problem.

It’s hard to find what is forcing the staves to display by just looking at the score, since what is displayed and hidden is also affected by the happenstance of where the system breaks occur. If you look at the individual parts, you can see which rests have not been consolidated into multirests, and that is probably a more accurate way to find the problems. Try selecting the “bar rests” and deleting them. Even a single bar between different time signatures should show as a one-bar multirest in the parts, unless something is stopping that.

It might be worth going to Edit / Preferences / MusicXML import and select the minimum set of options to get the notes and lyrics, but not force Dorico to follow all the formatting in the MusicXML.

I didn’t do the complete job of sorting this out, but if you can get rid of all the broken multirests and single-staff time signatures, that will probably fix most of the problem.

You could also try installing Musescore (free). It has good MusicXML support - if there are any errors in the MusicXML file, it will probably flag them. Just re-exporting the MusicXML from Musescore might give better results in Dorico if it cleans up some of the “features” in the MusicXML file.

Thank you for your suggestions. I’ve tried changing the time signatures and assigning them to individual staves but it doesn’t seem to be working. If I take the first voice which enters, S. Altezza for example, I am unable to hide its staves on measure 64.

If anyone could help with just diagnosing what is wrong with this one voice, I will take the solution and replicate it on all voices.


I spent untold number of hours working on this transcription and it is a little frustrating that Dorio is unable to hide staves based on what is actually hidden. This absolutely needs to get fixed. Furthermore, there needs to be a per-measure override for the inclusion of a measure for hidden staves, regardless of the musical contents of that measure. In other words, I need dorico to hide a stave based on what the user wants hidden, not dorico. By all means, lets automate everything but I really need a way to force blank measures off of my layout because as it is, i’m not able to complete this project which we are supposed to be running in rehearsal this evening.


If you look at bars 56 onwards in Galley view, you have incompatible time signatures on different staves everywhere, some displayed and some hidden. If you clean up all that, things will probably work a lot better.


Sorry to lead you up the garden path here with the comments about time and key signatures, but I’ve just remembered somebody else who had this problem, and what the fix was.

It’s a bug in the way Dorico imports lyrics from MusicXML. In some situations, the import gets confused and Dorico thinks the last syllable before a rest actually extends up to the next syllable after the rest. Therefore it doesn’t hide the rests, because it thinks there are some lyrics in those bars.

The fix is just to delete the last syllable before the rest, and re-enter it. If you delete the “-chio” in S. Alt. bar 59, you will see hyphens appear under all the following rests. Re-enter the “-chio” syllable, and the rests are hidden.

The same trick works in bar 263, and for C.Lam in bar 338, etc.

At least it’s quick to fix it, even if it took a long time to figure out what the problem was!

There is a different problem with C.Rap on page 12. There is a hidden time signature change on just that one staff which stops the staff being hidden. Delete the 3/2 time signature flag on the bar in the middle of the system (not the one at the start) to fix it.

Thank you very much you just saved me! It worked!!

By the way, there were no lyrics imported as XML data, it was just the notes, so something else must have caused it to not hide the measure, but either way, your fix worked!

I still think, however, that a manual override toggle for forcing the inclusion of a measure to a hidden stave, regardless of the data contained within that measure, is a critical function we need-even if the algorithm worked perfectly for auto-hiding staves.

Thanks again!