Hide bar number does not propagate

Dear fellow Doricians,
I stumble upon this problem today and thought maybe it was worth mentioning it here, since the behavior was not the one I was expecting.
When using the change bar number function, and hiding that bar number, if I select the signpost and propagate properties, that bar number will still show in every other layout (all parts and custom scores associated to that score). Is this a bug, or is it a way to tell us “you should have chosen the Don’t include option in change bar numbers, not reapplied the same number as the bar before”?
I attach a dumb project that exhibits the problem in case it’s needed. It’s zipped.
hide bar numbers don’t propagate.dorico.zip (445 KB)

Yes, unfortunately you can’t propagate properties for system items like time signatures, tempos, chord symbols, and so on. The ‘Hide bar number’ property is part of the time signature and thus cannot be propagated.

Ok, Daniel, thanks for the explanation!