hide one staff of multi-staff system

Hi all,

I am pleased that the option now exists to hide individual staves of a multiple staff part. However, either it doesn’t work completely or I’m missing something.

I have a part that goes back and forth between vibraphone and marimba. The marimba part is always single staff. I activated the “hide individual staves” option. It works most of the places – but does NOT work when the marimba enters.

I start with vibraphone. When I switch to marimba, in the first system with marimba, I get the “grand” staff for it, even though the bottom staff is not being used. In the next system, the bottom staff goes away. When I switch back to vibraphone, I get the marimba grand staff again, just prior to the switch.

Somehow, at least in my case with two instruments to this player, the hide empty staff for marimba is not properly and/or completely implemented. I hope this gets fixed in the next update??

The fix for hiding staves still does not take into consideration the practice, in many orchestral scores (for film work or classical work) where one wants to have some empty staves showing. The practice is to have facing pages with the same instrumentation. For example, if pages 4 and 5 have flute entering in the second measure of page 5, I would want an empty flute staff on page 4. I don’t think this is possible with the current set up.

David Froom

It would be good to select the staves I want to hide per system and click or shortcut to hide them.

Sorry to take so long to reply to this. I’ve tried to reproduce this problem in the attached pretty trivial example but have been able to. If I tell Dorico it’s allowed to hide one staff of a multi-staff instrument if empty, it does this happily for the Marimba, including on the system where the switch to the single-staff Vibraphone occurs.

Can you attach a picture or better still a project that demonstrates the problem so I can look into this further?
hiding-staves.dorico.zip (124 KB)

Hi Daniel, and many thanks for writing back.

I can only imagine the backlog of messages you must have to sort through – heavy price to pay for (I’m guessing) taking at least a few days of well-earned Christmas/NewYears break while also preparing for the upcoming shows.

In the example you sent, take a look at your vib/marimba part (as opposed to the score). Note also how your marimba part, as a single staff, still has the grand-staff brace.

In the attached, the problem occurs in both part and score. Look at m. 40 (fixes itself in m. 43). Then again at 53-60 (some back and forth).

While you are at it, can you advise on how I can hide the rests in the piano when I do cross-staff beaming? I tried making them white/transparent. They still show up in print mode: see piano in m. 1 and mm. 12-14.

Could the issue be that I started this in the previous-but-now-updated version of Dorico? That did bite me in one regard: I had set the sounds to play back with Garritan, and the connection to Garritan disappeared with the update (which must have replaced the hidden library file I had to edit for Garritan). I haven’t bothered trying to figure out how to go back to Steinberg instrument playback, nor did I want to fight with those files again to reinstate Garritan…

My long term project is to learn Dorico while re-engraving this 25-year-old work of mine (the Finale file provided the material for dozens of performances, but it is not at current standards). I’m stalled right now waiting for Dorico to update how it handles pedal marks, as well as some music spacing (99% of which is amazing, but even still here and there needs a tweak). And, of course, waiting for complete control over empty staves (that I need both for the vibe/marimba and more generally for doing anything orchestral).

Thanks again, and I look forward to hearing back from you.

Chamber Concerto.dorico.zip (406 KB)

Thanks – I can now see the problem. Going from two staves to one works properly, but going from one staff to two doesn’t, for some reason. We’ll take a look at this and try to sort it out in the near future.

In the forthcoming 1.0.30 update, you will be able to choose whether or not the brace should still appear when one staff of a grand staff instrument is hidden, using the options on the Brackets and Braces page of Engraving Options.

As for the rests in the piano, if you go to Notation Options, and choose the Rests page, set the option (added in 1.0.20) ‘Bar rests in additional voices’ to ‘Omit bar rests’, and that should take care of it.

Thanks, Daniel,

I’m not sure what you mean (2 to 1 works, 1 to 2 doesn’t work). I want my score/part all to be 1 staff to 1 staff. Maybe you are saying that had I begun with marimba instead of vibraphone, this WOULD have worked? But, in the example you sent, which worked in the score view, it had the same problem I am having in the part view.

Ultimately, I hope Dorico will allow full control over which empty staves show up and which don’t on a part-by-part, page-by-page basis? This is truly needed for the program to be a “prime time” candidate. I guess this won’t come in 1.0.30 – though I DO look forward to other improvements, as it is a pleasure to watch as Dorico moves forward in such large leaps and bounds!

I went to Notation Options/Rests, and under “Bar rests in additional voices” chose “Omit bar rests.” That did not fix the problem. Try it with my score, then look at the piano in mm. 1, 5, 12ff. The undesired rests remain. I fear “Omit bar rests” applies only to single staves, not to grand staves using cross-staff beaming. I wouldn’t mind just hiding the rests (making them transparent and/or white), but that doesn’t work – they still show up in print view.

Thank you again for your kind attention.


Marimba is a grand staff instrument in Dorico (even if one of its staves is hidden because it’s empty), while a vibraphone is a single staff instrument, so when you switch from marimba to vibes you’re going from 2 to 1, and when you switch from vibes to marimba you’re going from 1 to 2. Dorico allows one of the staves of the grand staff instrument to be hidden when you start the system with 2 staves and change to a single staff instrument, but not vice versa. This is simply a bug that we will fix in due course.

Well, perhaprs, though that wouldn’t be easy to achieve, because unlike other scoring programs, where the staves present on all systems is always the same for the whole duration of the project, Dorico’s dynamic nature means that staves can come into and out of existence from system to system, which greatly complicates the notion of whether or not a stave can be hidden or shown explicitly.

This option does definitely apply to bar rests in passages of cross-staff writing, and it certainly does fix it in your score in bars 12 following. There is no cross-staff beaming in the piano part in bar 1 or bar 5, as far as I can tell: simply two voices written in the RH staff. If you actually write those first two 16ths in a voice on the LH staff and then cross them onto the RH staff, then the bar rests in the LH staff will no longer appear.

that wouldn’t be easy to achieve, because unlike other scoring programs, where the staves present on all systems is always the same for the whole duration of the project,

Can you explain this further?
In Finale, I constantly (and quickly) choose which staves to view/hide on a system-by-system and layout-by-layout basis.

In Finale and Sibelius, all staves that exist in your document exist on all systems, so there is a fixed list of staves for the whole score, and you can choose which staves are hidden or shown from system to system, because all of those systems exist always.

Dorico works very differently: staves are transient, created on demand for each system, because the design of the application is such that the layout is much more dynamic, with the music for each instrument able to flow between different staves, in service of producing (for example) a condensed score where music for multiple instruments can dynamically be squeezed onto a smaller number of staves. Although this feature will not be fully visible in the software for some time, the design of the application has been made with these kinds of features in mind.

This is the same reason why you can’t work with brackets and braces the same way in Dorico as you can in other applications, because there’s no fixed list of staves to hang the data on.

My commitment to you is that these apparent hardships will be more than compensated for when the application becomes more mature and these features are in place.


Think for a moment about the Play mode.
Where an instrument doesn’t play, there is a blank space. Now think of this as a metaphor for staves in Dorico. When you “hide” a staff, it doesn’t hide, it stops, much like a secondary voice when you use “Start Voice” and “End Voice” commands.

Although I am not a Dorico team member, I think I understand how this is constructed. If sounds start and stop according to a MIDI timecode, that means they do not exist when they are not sounding. This is what allows Dorico the flexibility it has with changing time signatures. I expect the appearance of staves in the score (although not quite the same) is similar in nature, keyed somehow to the equivalent of MIDI timecode.

Apparently in its current iteration Dorico can stop a staff more easily than it can create one mid-flow. That’s how I interpret Daniel’s comment.

Finale, as we know, uses persistent staves organized by measure.

EDIT: Well, I guess I sort of understood a piece of it. Thank you, Daniel, for the real explanation.

All interesting… but this sounds like I may be left with staves that I want hidden that there is no way to hide…?
Whether or not there are notes is not a 100% reliable guide as to whether a staff needs hiding.

Nor is it a reliable guide as to whether the staff needs showing!


OK, now the cross-staff bits are fixed! Thank you!! I had put in half-rests to be able to grab something to hide. When I took them out, everything works as you said it would.

I’m still stuck on how to do m. 1. If I put the downstem dyads in the LH staff and move them up, I get still the 16th rests that I can’t hide, and I get NOTHING in the LH staff. I want to show RH/LH in the upper staff with down/up stems (and no rests), and I want a default whole rest in the LH staff. Is that possible? I think it would be if making rests transparent worked throughout (they are hidden in write/engrave, but show up in print – and then they print).


OK. You don’t need to put the downstem 16th notes on the LH staff and cross them to the RH staff, which will, as you point out, hide the bar rest in the LH staff once “Bar rests in additional voices” is set to “Omit bar rests”.

But there’s a proper way to hide at least the second 16th rest in the upstem voice in the RH staff. Undo all of the colour and position properties you’ve set, and then select the rest between the two upstem 16ths and hit Delete: this won’t actually get rid of them, but it will ensure that they are now implicit rests that can be hidden by way of properties. Then select the first 16th note and set the “Ends voice” property.

Unfortunately hiding the first rest in the upstem voice using properties is not yet possible, though one way or another I expect this will be possible soon. So for the time being you can use the colour or transparency trick to get rid of it, and if you switch on the ‘View options’ checkbox in the print options panel, you’ll find that it is successfully obscured when printing.


Actually, what I needed to know about was “View options.” What exactly does that mean? What it seems to do is allow transparency changes in properties of Engraver mode to carry through to the printing. Why wouldn’t we want to do that? And why would “View options” on make that difference? And what else does view options do?

Bigger question – if you have the time. On page 4 of the score I previously attached, the upper system vibraphone (doesn’t play for these measures) shows no rests nor measure lines. In Galley view, this looks fine, but in all page views (write, engrave, print) that one line of score is messed up. There are no notes there. Can you help find why this one spot doesn’t display correctly?


The ‘View options’ checkbox in Print mode specifies whether the various things that appear in the score, like signposts for hidden time signatures, system/frame breaks, etc., should be included when you print or export graphics. This also currently controls whether some things print in colour, which is really a bug, and should be fixed in 1.0.30 (i.e. you’ll be able to leave the ‘View options’ checkbox switched off and still print or export in colour, though I hope you will also be able to suppress the initial rest without recourse to changing its transparency or colour in 1.0.30 as well).

The problem with the vibes staff at the top of page 4 is something related to the hiding of empty staves. Looks like a bug to me. We’ll look into it.

Thanks Daniel!!

Now I remember. I turned View Options off to suppress the signposts (who would want them to print, except for pedagogical purposes?). But to have that turn ON signposts while also being the only way to allow transparent things to stay hidden, sadly, seems to be at cross purposes. Nevertheless, I take solace in your awareness of this as a bug and promise to address it in the future (if not 1.0.30, then we hope the next one).

Looking forward to 1.0.30. If it is as big a step forward as the other updates, it will be exciting to see.

A few steps at a time. Getting closer and closer.

Fascinating bug that vibes staff on page 4 … I found it went normal by entering a time signature in bar 22 (and hide it) … :open_mouth:

But, since I have “View options” checked, hiding the time signature wold place a signpost that I can’t hide…

But that’s an interesting thing. I’ll mess around with it and see if there is a way to get this to work – or maybe, I’ll just wait until 1.0.30


You can temporarily hide the signposts using the options in View > Signposts, of course, though it can be confusing to work that way for very long.