Hide rests

Burton: so far, being new to Dorico, I’ve only found 2 postitions to put rests in the first voice and they both end up in the staff. Is there a way to move them further? I personally think any object on a staff should be able to be made invisible.

You can move a rest by selecting it and then using the ‘Rest position’ property, which you will find in the Properties panel (you may need to scroll the panel to the right).

I’d just found that and was going to post it. I don’t think I scrolled over far enough to see the number box, but it works for the rest not to show without affecting the rhythm. Trouble is, I still have a work in 2/4 with an upbeat in the first bar and I’d like to get rid of the first quarter rest. I’ve seen this done in 19c engraved works.

You should use a time signature of 2/4 with a pickup. That way there won’t be a rest to hide in the first measure.

FAQ instructions:
How do I hide rests?
If you are writing in multiple voices on the same staff, you may want to hide rests before or after the notes in a secondary voice. To hide the rests before the first note in a voice, select the first note or chord in that voice, then open the Properties panel (Ctrl+8, or choose Window > Show Bottom Panel in either Write or Engrave mode). Find the property Starts voice and switch this on: any rests in that voice prior to the selected note will no longer appear.

I followed these instructions above as suggested. The 1/8 notes in the attachment are the primary voice. The stem up 1/4 tied to 1/8 are the secondary voice. As you can see, the “Ends Voice” worked to hide the rest but when I select the 1st 1/4 note in the secondary voice and try to switch on the “Starts Voice”, the switch does not stay on.
Hide rests .png

Someone from Steinberg will have to confirm this, but this appears to be a bug. It seems that if the first stem-up voice starts later in the bar, that first rest won’t hide. If you start with the moving 8th notes in the first stem-up voice and add the thumb notes in voice two, the rests can then be hidden. But of course, you have to mess around with stem directions in beats 2 and 4. Doing one bar, selecting it, typing R for repeats re-pitching notes with Alt-arrow keys, and “ends Voice” on the notes preceding the rests is probably the fastest way to deal with notating this until they fix it, which I assume they will.

I suspect the dotted quarter rest at the start of bar 9 is an explicit rest, in which case Dorico can’t remove it. Try selecting the rest and deleting it (which will make no visible difference), and the ‘Starts voice’ property on the first up-stem dotted quarter note should do the job.

Hey folks,

I’ve attached two images. Any chance you guys could point me in the right direction for making them look a bit neater. I had a bit of a mess around with the settings and I can’t seem to get rid of the bass stave semibreve rest, nor can I seem to get the colouring thing to work.

Cheers!
Cross-stave 2.PNG
Cross-stave.PNG

By colouring thing, do you mean “hide the rest using opacity at 0” ?
One very important thing for this to work in the Print menu is to check that you print in colour and at the bottom of the right panel (Annotations), that View options is checked.
Capture d’écran 2016-12-19 à 15.31.32.png
Hope it helps !

Thanks! Where do I find the opacity settings, because I couldn’t see where you change the opacity of an item to 0?

Am I right in understanding that Dorico will eventually hide these unneeded rests automatically?

In the color picker dialog, it’s called “Alpha channel.” 255 = completely opaque, 0 = completely transparent.

This does not seem to have any affect. I have tried editing this setting in write mode and engrave mode, sometimes I change it, click away, and then click back and it has returned to being turned off… or it will remain on and transparent, but still show in the PDF version and in the preview of print mode. :confused:

In the case of the dotted 1/4 in voice 2, you were correct. I deleted it (explicit rest), then applied “Starts voice” and it disappeared.
In this situation (see attachment), no explicit rest. I cannot get it to work for voice 2 (1/4 rest and 1/4 note).
Screen Shot 2016-12-19 at 10.18.53 AM.png

shouldn’t you be able to change the color of the rest to white or change the alpha channel to ) to make it transparent, then when printing or exporting be sure choose color and not mono to print, annotations and check view options box. this has come up a few times but seems to get lost in the growing forum. this does seem to be a big problem for people. I know daniel mentioned that it would be fixed for rests in a part with more than one voice (I believe he said) in the next update.

Yes, I know I can make it transparent, but according to Daniel the “Starts voice” should (and did in one instance) work. Just wondering if this could be a bug.

What worries me is that a copying job in the nineties that paid enough for a weeks work, now pays enough for a day.
So speed, small number of keystrokes, and not breaking workflow to click in a properties panel are probably more important than prescriptive syntactic meaning.

But when “music copying” has becoming the same sort of long-term career option as “copy typist” or “telephone exchange operator”, notation software that understands semantics is exactly what the next generation of musicians will need.

To communicate with emails, texts, social media, etc, is “not breaking workflow by using a proper full size keyboard” more or less important than “predictive text entry and typing with two thumbs?”

Hi Rob,

I disagree. Plates and calligraphy have gone, but the kind of thing I do most of (clear, correct, quickly-produced parts for performance and studio sessions) is still a marketable skill. In fact, I’ve been brought onto jobs where the composer has produced the charts themselves, but the charts lead to so many questions (on the clock…!) that its better to get them done properly. My job is to anticipate everything that might waste a minute in a session.
Whether hiding a rest leads to more or less readability is not (always) a semantic question.

It works OK for me. Try moving the up-stem C to the staff position above and then set the ‘Starts end’ property, and that shoukd take care of it, then put the note back to the original staff position.

Not working for me, are you using mac or windows?