Hide tracks not in use suddenly not working?

Made a macro to hide disabled tracks, and it works, but not for these 2 tracks I’ve used shortly and then disabled in this project.
Any idea why?
I’ve enable/disabled tracks before where I could hide them again, so not sure what’s going on.

They are not shown in the mixer panel though.

Oh there’s a dropdown menu for it. Guess I didn’t even need that macro.
It worked doing it in there.
Problem solved I guess :smiley: