Hiding dots of a dotted rest

I’m doing an X-meter measure. For one player it starts with a quarter note, followed by a quarter rest, and then a bunch of other rests to fill out the measure: a double-dotted whole rest, a half rest, and a sixteenth rest. I want to hide all the rests except the first (quarter). No problem, I just set their opacity to 0%. But the two dots of the double-dotted whole don’t respond to the opacity setting, so I have those 2 dots floating in limbo. I fixed it by force-inserting the appropriate rests without dots, but is there something else I’m missing, or is this a little bug? (Or a feature…)

Can you select the rests and use Edit -> Remove rests?