Hiding hairpins

I could use some advice on hiding hairpins. Often, when working in condensed staves, I will have similar, but not exactly the same, dynamics in two different voices. In those cases, I might want to hide one set of the dynamics attached to one of the two voices and create a single combined set of dynamics for both parts. I know it’s easy to hide intensity markings, but not hairpins. So, what’s the workaround?

Here’s what I’ve tried:

  1. Set hairpin scale to 1%. This however creates two issues: first, it does not remove the element from collision avoidance–which is not an issue if I’m hiding things above the staff as much as below, where I ultimately want to see the visible dynamics; and second (most important), this property affects the appearance of the hairpins everywhere, so I no longer see them in galley view or the parts. Of course I did not realize this at first, so I’ll have to go back through so many measures where I’ve already done this and try to find those places where I had not realized they’re forever hidden. (By the way, is there any way to search for items with 1% scale if you cannot see them?)

  2. Set opacity to 0—but does this not create the same issues described above? Is opacity a local property but scale global always? I am a little confused here because when I select “Show local only” in the properties panel, I still see scale and color, but when I change the scale it certainly changes it everywhere.

  3. Try to find some way to make the dynamics look exactly the same in galley view such that I can trick Dorico into recognizing them as equivalent, and therefore condensing them on the staff automatically. This is really hard, and though I’ve managed to make it work in some cases, in others I just cannot. The issue here is that it can require placing a dynamic under a rest, for example, which Dorico does not want me to do. SO I end up grouping and linking and unlinking and ungrouping, etc., etc., until something seems to hit. But I have no idea how or why it works when it does.

When you say “voices”, you mean two different instruments that are now on the condensed staff?

Make the dynamics exactly the same (in Write mode), and then, in the Layout where they need to be different, make them not exactly the same in Engrave mode.

(I.e. if you’re only showing one of them in the score, then they are essentially ‘the same’ in the score.)

@benwiggy Thanks for the reply. Sorry, I should be clearer:


Here you can see two trombones on the bottom staff. I do not need to see the dynamics above the lower staff since it’s clear that the crescendo in both parts reaches “mp”.

In galley view, I have this:
Screen Shot 2023-08-05 at 8.39.55 AM
I need to maintain these dynamics for the parts because it would not make sense to show the second player crescendo without the arrival on “mp”.

Thus, I cannot make the dynamics exactly the same in write mode. I cannot force the “mp” in the second part to attach under the rest. Well, to be clear, I’ll say that the dynamics are all attached to the same point, but Dorico does not calculate the “mp” in the middle staff such that it will ever place it at the same position as the bottom staff “mp” when condensing.

Does this instance help to clarify my issue? Of course the easy solution would be to have a “hide” function for the dynamics, but that does not exist unfortunately.

Next to „show local only“ should be two more buttons: global and local. Make sure you are set to local and scale will only affect the current layout.

1 Like

Ah, ok, thanks! I’m guessing though that any previous undesirable global changes I made are hidden forever though, right? Unless I can remember where they were….

I would select the music and filter by gradual dynamics, with properties set to global check and/or uncheck the scale property. This will reset of course also other scalings you would maybe like to keep.

@klafkid thank you.

@klafkid Well now that I’m back at my desk, it seems that both properties are set to “local” and yet any changes I make to the scale affect all layouts and galley view.

Can you send a screenshot? It doesn’t matter if „show only local“ is set, it just filters for properties that can be set locally exclusively as well as both local and global. The important button is the „local“ button.
Another hint: if after activation a property it’s bright white and bold, then it‘s set for all layouts. If it’s just bright white, it‘s set locally (dark mode)

This is what I see in engrave mode:

With this setting, the dynamic is invisible everywhere.

Did you make sure you were resetting it in all layouts?

I definitely scaled items in individual layouts before.

You are indeed correct. The scaling is local only to the current layout. However (and this is what confused me), the scaling transfers to the score in galley view. Thus, anything scaled to 1% is invisible in galley—which feels dangerous for me. If I need to make edits to the score I would have know way of knowing what is actually in the parts without going through each one individually.

Am I missing something else here? Should the scaling transfer to galley view? It seems odd that anything layout-specific should transfer to galley view.

Galley View is still based on the current Layout, even if it’s not paged. If you exclude a Player from the Layout, it won’t appear in Galley View. Other pertinent settings in Layout Options will also apply.

1 Like

@benwiggy In that case, there would be an easy solution, which would be to create a second full score layout that is not part of any engraving adjustments, and then just refer to that when necessary. Thanks!