Hiding instruments, changing clefs

Hello all,

I have a score for



As I want to have control over where to show empty staves and not, I have that layout option set to “Hide empty staves always” and add empty (spacebar) text where I want to show them.

At a certain point in the movement, the basso part is divided into vlc and basso. I have created the vlc as a separate player, and I want this split section to begin on a new line, so I added a system break. The vlc enters with notes in tenor clef, and the problem is that the clef change will be visible in the form of extra space added to the end of the system before, even if the vlc staff is hidden.

How can I set the initial clef of the vlc to tenor clef to avoid this? Or is there some clever way of solving this that I just don’t see?


LAE, can you not change the vcl. clef to tenor right at the beginning of the flow (or score)?

Then the vlc staff will show. I want it hidden from the start.
I need a way of setting the initial clef without making a “normal” clef change.

Start a new flow at the point where the Cello enters?

Can you give us a (shortened) version of the project file that displays this problem, please?

I’ve tried to reproduce it here and I can’t - Dorico doesn’t make extra space - which suggests I’m doing something different to what you’re doing. See attached.
clefproblem.zip (703 KB)

Thanks Pianoleo, my mistake, one piece of info missing. I have repeat marks like in the screenshot. If you add them, you will see the problem in the file you so kindly provided.

Yes, thanks, that did it! Smart.