Hiding lines in specific layouts

I am looking for a way to make a Line appear only on the part layouts and not in the full score layout.

Is this possible? Couldn’t find a way to either create a line only in the current layout or hide a line from a layout.

Thanks.

The usual workaround of scaling to 1% and colouring white seems to work - ensure the “Set local properties” toggle is set to “Locally” before you do this.

Thanks, that’s a good workaround. Hopefully lines will get a Hide property in the future.

Definitely something that’s needed. Custom lines tend to have some characteristics similar to technique items. Technique markings already have the option of hiding in specific layouts.
By the way, that’s another workaround: create a new technique with no symbol, set its continuation property as a line and voila, there you have your line with the option to hide it in specific layout.

I had always managed this one with turning the colour of lines white.
I have to hide a line with a hook but note that, even doing this and reducing the scale to 1%, I still get the hook showing.
This always worked OK with earlier versions of Dorico but not with Dorico 4.
It would be great to be able to hide the lines (as is possible with text and playing techniques).

Edit: I’ve just opened the file in 3.5 and reprinted the score - the lines have vanished as hoped for!

Andy, can you provide a simple example project that demonstrates the problem? I find that when I override the colour of a line, the whole line, including the hook, is correctly coloured.

I am using for the guitar a vertical line+ right-pointing hook as a barré.
If I just set the colour to white, then this shows up against the stave.
If I set opacity to 0% (which I was in the habit of doing in 3.5), this looks fine in Write mode, but in Print mode and printed output, the vertical shaft still shows.
The same applies if I set the colour to white.
Hide line test.dorico.zip (2.5 MB)

I have also tried setting custom scale to 1 - it looks fine in the Print mode but the pdf still has vertical lines - though the hooks have vanished.

I tried this, even with a default vertical line, but still get the problem. The line I have use is a modified custom line with lower R. hook (sounds like boxing!)
If one opens this test file in 3.5, filter vertical lines and set opacity to 0%, then the lines disappear on printing.
Doing the same in version 4 still leaves the vertical part of the line - I append the print pdfs.
Hide line test.dorico.zip (2.5 MB)
Hide line test-3.5.pdf (21.4 KB)
Hide line test-4.pdf (21.5 KB)

Sorry for not coming back to this thread yet, but there’s no need to bump – this is definitely on my list to look into, and I’ll come back to you once I know more about the nature of the problem.

Sorry to bump - I just thought it might clarify.
And I quite understand that you might be a little busy!!
Andy

It’s taken me a (very) long time to come back around to this, for which I apologise, but I just wanted to say that I have spent some time looking into this and have identified the problem, and we should be able to get it sorted out for the next update when it comes. Sorry for the delay in closing the loop!

1 Like

Just noticed that, in Dorico 4.1, using Colour → Opacity 0% in the properties panel now makes the vertical lines invisible when printing a pdf! Hooray and many thanks (probably to Daniel).
(I didn’t find a reference to this improvement in the Dorico 4.1 Version History though.)
I suppose that, one day, we’ll be able to hide lines so that their spacing no longer affects the score?

Yes, I did indeed fix this (and I think it is documented in the Version History PDF). I don’t know about hiding lines in one layout. Can you say a bit more about the specific use case you have in mind?

Hi Daniel,
I’ve got a use case for line-hiding in score & showing in parts. Screenshot shows a gesture for strings with an identical group dynamic and bow contact point transition transition to sul pont and back to normal bowing position (–> SP → N). Ideally I’d like a single LARGE version of → SP → N above top staff and a single LARGE version of the group dynamic under the bottom staff. I would show the large version in the score only and the small versions in the parts only. My Dorico chops are still decidedly inchoate so there may well be a suitable method, but at my current skills level I’m going to leave dynamics as they are and use scale and opacity changes to get large/small shown/hidden arrows.

Screenshot 2022-07-31 at 00.22.09

Update: I’ve found my workaround. Scale & opacity did the trick. Bit tedious but good result. Maybe I get faster.
Screenshot 2022-07-31 at 01.04.34

1 Like