hiding partial rests

hi there,

I’d like to hide some rests, both in the beginning and at the end of a bar.
I’ve hidden them in Engrave by colouring them white and setting the opacity to 0%, and moving them out from the stave.

When I turn off note colours, I don’t see them in Write or Engrave – however, they come back in Print.

How can I make sure these rests do not appear in print or PDF exports?
Attaching example…thank you!
hiding_rests.jpg

Have you set the printing option to “colour”, and checked the Annotations View options?

hmm, so yes, I’ve done that but

– when I check “view options”, it removes the hidden rests, but this way it also exports the annotation marks (system breaks, etc.) into the exported PDF.

– When I uncheck “view options”, the system formatting handles disappear but the hidden rests make a reappearance.

can’t win…

You can hide system breaks in the menu View -> Signposts