Hiding Rests!

Hi guys, I have heard the methods for hiding rests in Dorico, but THIS kind I cannot seem to hide. It is in 3/4…the 1st 2 beats are crochet rests and the 3rd beat is a note. Now, I want to hide the 1st TWO crochet rests in the 2nd voice. HOW?..is it done?

https://www.youtube.com/watch?v=LoyxnSTT5qc&feature=youtu.be

Thanks guys.
Hans

The quickest way by far is to select the rests and go Edit > Remove rests.

1 Like

The alternative method is to select the G# in the downstem voice BEFORE the rests, and tell that to end voice immediately. Then select the E quaver/eighth following the rests and tell that to start voice. (This is precisely what “Remove rests” does)

Thanks Sir. This is a great relief if it will work. Going to try now! :slight_smile:

EDIT: A-HAAAAA!! It works PERFECTLY…Thank You!

ONE QUESTION: How do I do your 2nd option…“END Voice Immediately”?

AND…WHILE i’m hiding stuff…do you know how I can “Hide Empty Staves” in Engrave mode?

Thanks

I’m not in front of the computer just now, but early in your video you complained the the “Start voice” and “End voice” switches (in the bottom properties panel) don’t work. It’s those switches you need in my second method.

For clarification: they work but they apply to the note or rest that you’ve selected.

If you’ve used “Remove rests” already then you can click on either of the notes I mentioned earlier, and see how those switches have been used.

Hide Empty Staves is a layout-wide function. It’s in Layout Options > Vertical Spacing.

THANK YOU SO MUCH!
Season’s greetings to you!

I am having trouble with doing this on the rests in the upper voice in the beginning and end of this figure, for drum set in V1.2:

You can’t hide rests in percussion staves at the moment, unfortunately, Hans. We may be able to support this in a future version, but we cannot at present.

Matanr, out of curiosity, is that a common practice? My organist’s brain can’t fathom voices unaccounted for. Alas, Bach seems to have beaten it in to me. I could certainly see this as useful for beats where the rhythm is the same (the share rests option that already exists for non-percussion staves), but for polyrhythm on the same stave that seems risky. As I’ve never had any reason to write for drum set, I’m genuinely curious. :stuck_out_tongue:

Edit: In this particular example, the rhythms are not that different so I suppose it is not too “risky”.
Suggestion: you can select the rests you do not want to see and opt to change their color. When the options pop up, you can change the alpha channel to zero and they will not display/print even though they exist within the score. Cumbersome for more than a few things here or there, but it would certainly work in the meantime.

Unfortunately you can’t use the “make things transparent” trick for rests on staves for percussion players using the grid or five-line staff presentation types, because explicit rests are not allowed there – the same reason that Remove Rests doesn’t work, too.

I’m not in front of Dorico now to check it, but doesn’t make the trick scaling rests to zero (new custom scaling option)?

So the following situation (compare LH Pno and Perc staves) is not a rests bug but a rests “feature”?
doco1.2-init-rests.PNG
Disallowing explicit rests in the drumkit staff therefore results here in a glaring inconsistency right in measure 1. Is this constraint on the five-line percussion staff temporary or permanent?

For a 5-line drum staff - no. You can enter a custom scaling number, but nothing happens in the score.

Boscoverdi, I would say that nothing is permanent, but changing things such that you can edit rests directly on five-line staff or grid presentation types is not something we will be able to do in the immediate future. You would not need to edit the rests if you were able to specify the beat grouping for your time signature properly, which I guess you cannot because you want to use a 5/4 time signature but need beat subdivisions of dotted quarters. One option, though not for the first bar, is to use something like [3+2+1+4]/8 (or whatever) in the second bar, and hide it, then you only have to manually fix the beat grouping in the very first bar – which I accept is still impossible in the percussion staff regardless.

So I am trying to remove rests from entirely empty drum set measure and nothing happens. Is this also a problem without a solution?

There’s a global option for showing empty bars as completely empty (without any rests at all) - is that what you’re aiming to achieve?

I’m hoping someone can help me with this issue too. I’ve managed to delete the lower crotchet rest but now need to hide the upper dotted minim rest. I’ve tried both methods stated above and it won’t go away. What a pain this is (for us contemporary composers)! I get the logic but it seems such a steep learning curve when a simple delete would suffice. Any ideas?
Screen Shot 2018-03-03 at 01.02.00.png
Screen Shot 2018-03-03 at 00.46.44.png

Hi Patrick. You did select that dotted minim rest, have gone to Edit menu, chosen Remove Rests and the rest is STILL THERE ? This is really weird. This is not a percussion staff, is it ?

Hey matanr! I found a way to hide unwanted rests in percussion staves, assuming this screenshot is what you’re trying to achieve.

The trick is to make a 4:2 tuplet (if you have 4th notes selected) with a whole note in it, then you can hide the whole note and the 4 that appears. You can mute the whole note if you don’t want to mess up playback.