Hiding Rhythm dots

I’m able to hide a rest by changing its opacity to 0%, but for some reason this doesn’t affect its dot. Is there a way around this other than separating it into its constituent un-dotted rests?

In general it shouldn’t be necessary to hide rests by changing the opacity. Are you using the start/end voice properties appropriately, and the Edit->Remove Rests command?

Yes. I’m trying to have a recitative/cadenza bar, which isn’t well supported yet. I’m removing rests in the voices that don’t have the recitative, so they can’t see the true duration of the bar.

OK, I hope you don’t mind me asking :slight_smile:

One option for things like this is to switch to the open time signature (Shift-M “open”), then hide the time signature and write the cadenza material in an unmetered bar. Then the other parts will just have a one bar multirest.

As for your specific question about opacity of rhythm dots, I don’t think these can currently be made transparent. Your best option is probably to use Force Duration to enter a combination of rests that don’t have dots, then make all the rests transparent.

It is in an open time signature, but it’s a recitative, not a cadenza, so some of the other parts are holding notes. I would like to have a whole note, not a bunch of tied notes of various durations.

I’m aware of the option of separating a rest into its constituent un-dotted rests, but this is more of a workaround than a solution, and certainly not the intended functionality.
So I’m wondering if it’s an oversight, or if I just don’t know how to do it.

It sounds to me like you know all the options that are currently available but maybe someone else knows more than us!

Pardon me, I might be missing your point here. Can you explain again why you can’t use “Remove rests” function in the parts with long notes?

This is an example of using a hidden open meter and “Remove rests”:
Skjermbilde 2017-07-03 kl. 22.17.15.png