hidpi on, vst's unusable

I get by more or less so far.

But limiting our high resolution use on Windows systems, with nowadys variety of hires monitors, to 100% OS settings, just not to run into problems, that’s still an unacceptable limitation and a definite no go for 2019 software, which is heavily dependant on optical usability, isn’t it?

Agree it should and hopefully will be, at some point.

we recently went through all this pain (HiDPI) support with our own software. It’s very troublesome.

But if you have a 4k monitor and you’re running it at 200% scaling, you’re seeing everything the same size as if you just ran it at 2k resolution, except you’re getting the OS to do a LOT more work. 4 times the number of pixels, 4 times the video memory use, anti-aliasing computation etc etc.

There’s an argument to just run it at 2k. I doubt you’d actually see the difference, but the load on your system would be greatly reduced.

Agreed, but one problem is that there is not a great selection of 2K monitors out there. The TV saleman attitude that bigger numbers must be better seems to have squeezed one of the more sensible resolutions (2560×1440, “QHD”, “WQHD”) from the market.

Er, no, you’re seeing it at the same size as “1K” or FHD resolution.

what I meant was just run the 4k monitor at 2k resolution. This is easy to do on Windows, not sure about Mac.

Actually no. Have you tried this? I actually have.

If you run a 4k monitor at 2k resolution in Windows then everything is the same size as running it at 4k with 200% scaling. 4k and 2k refer to the horizontal resolution not the number of pixels overall.

and there is no “1k”. If you’re referring to 1080p, the 1080 refers to the vertical resolution, and is usually 1920 wide, which is 2k if anything.

most 4k monitors are 3840px wide.

If I have say, a 28" FHD (1920x1080) and I replace it with a 28" 4K (3890x2160) one, but I have to scale that 4K at 200%, the picture is the same size.

Yes. But in Windows you can run a 4k monitor at 2k resolution and it scales it without using screen scaling - e.g. you still set Windows screen scaling at 100%. So it looks the same as if your monitor were the same physical size but only 2k. The monitor itself (I believe) does the scaling.

I think we’re making similar points, just in different ways.

Although the high pixel density numbers of a monitor may be great specifications, I believe many people purchase 4K UHD monitors in the belief they will have more work area or “screen real estate”, but then find that features are almost invisibly small and having to scale to 200% results in exactly the same work area as they had on the FHD monitor it was replacing. Given monitors of the same dimensions, images may look smoother, but everything’s the same size.

yes that’s all correct. My point was that if you run a 4k monitor with 200% screen scaling, the OS is still dealing with all the pixels, and apps that don’t handle HiDPI properly will display improperly, such as VSTs.

If you run it at 2k resolution instead, your OS only has to deal with 1/4 the number of pixels (which saves a lot of work / CPU / Memory etc) and apps that can’t handle HiDPI properly aren’t affected since you’re not running screen scaling (it’s still set to 100%).

So there’s more of a difference than just slightly (hardly perceptible) smoother text etc.

I think their point was, the proper term for 1080p is Full HD/FHD, not “2k”. :slight_smile: That’s what got everyone’s feathers ruffled. (me? I enjoy a good feather ruffling.)

Hi everyone from Italy!
I had the same problem running NI Massive X and also Arturia Analog Lab 4 in my cubase 10.0.30 pro on my laptop running windows 10. I’ve got an Asus Notebook with 15" UHD screen and I’ve seen that the best compromise for me to have a good software display is to set the screen at 1920x1080 with 125%. In this situation, according to https://helpcenter.steinberg.de/hc/en-us/articles/360001589520-Cubase-10-HiDPI-support-on-Windows-10, cubase scales to 100% and this is good to me. Anyway, until a few seconds ago, the GUI was too small for Massive X and Analog Lab 4, so I couldn’t work with them.
I’ve found this solution on the NI support website: https://support.native-instruments.com/hc/en-us/community/posts/360006241018-Massive-X-GUI-not-working-on-Cubase-10-HDPI-en-us- and now it works fine.
I still can’t use the highest resolution of my screen (UHD 3840x2160 with 250% monitor scaling) because in this situation Cubase scales to 200% and some elements are really enormus (tracks, tabs, loading screen,…) and some others are really invisible (for example NI and other third part loading screens).
If you want to give a try right click on Cubase icon>properties>compatibility tab>modify for all users>
change high DPI settings>tick both boxes and set the first sliding window on “when this program opens” and the second on “application”.
Let me know if it works and hope Steinberg would fix asap all the displays options…


still no update for this… this is trully horrible :frowning:((((((((((( one of the best DAW… and they still can’t fix the main issue with scaling. I am fighting it every day in hope, it will be solved. I bought all upgrades (they claimed, there is a massive DPI update), it changed NOTHING… I mean really nothing since the vesion 8 as I remeber. Still the same. No able to use HiDPI properly. No able to scale the DAW and plugins. Issues, pain, issues and pain again.

Arturia plugs V5 don’t work in HIDPI. Boo.

+1, same problems with Trackspacer and MetricAB

Bumping this - any fix on the horizon? Most VST plugins are so small it’s unusable. Why can’t we just have an option to double/triple the scaling of the window?

not sure if this has been mentioned already but I might have found a fix for windows (tested it with Cubase 10.5 and softube plugins)

I have a 2k display (2560x1440) with text/app size set to 125% and running in HiDPI mode plugins looks good if I do the following:

  • From the Cubase installation folder (e.g. C:\Program Files\Steinberg\Cubase 10.5) right click on “Cubase10.5.exe” and select Properties
  • Under the “Compatibility” tab click on “Change high DPI settings”
  • Tick the “Use this setting to fix…” under “Program DPI” making sure “I signed in to Windows” is selected in the dropdown below.
  • Also tick “Override high DPI scaling behavior” with “Application” selected
  • Confirm / apply the changes
  • Open / restart Cubase in HiDPI mode

This seems to apply 100% text/app size (instead of 125%) to Cubase only which, as mentioned by someone in this thread, fixes the issues with some plugins.